User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: URGENT Help needed car isnt running very well

  1. #1
    Regular Member vanquis1979's Avatar
    Join Date
    Mar 2008
    Location
    gainsborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default URGENT Help needed car isnt running very well

    Hi got a problem with my cdti 150 sri car had a misfire this morning betwenn 1800 & 2200 in all gears and within 2 miles its lost power wont rev above 2500 spanner lights was coming on then off, then on all the time... now the spanner light has gone off and the orange engine light is on, theres no smoke just sounds very rough and no power? its sounds like its running on 3 cylinders (like a petrol) and the trip computer was reading 44 mpg and now only reads 28 i have checked to see if the 3rd injector has been changed and it hasnt before christmas it had new inlet manifold and full major service done and in feb was serviced again milage is 93000, can anybody help please i go on holiday monday

  2. #2
    Regular Member glenboy's Avatar
    Join Date
    Jul 2007
    Location
    Sunny Dartmoor
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Must be that exhaust you bought,i'll take it off your hands m8,probably only meant for a petrol anyways

    Only kidding m8 Have you checked your EGR???

  3. #3
    Regular Member vanquis1979's Avatar
    Join Date
    Mar 2008
    Location
    gainsborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    can the egr make the car run like that?

  4. #4
    Regular Member glenboy's Avatar
    Join Date
    Jul 2007
    Location
    Sunny Dartmoor
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I thought it could,sure its been talked about quite alot on here somewhere

  5. #5
    Regular Member vanquis1979's Avatar
    Join Date
    Mar 2008
    Location
    gainsborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    having the car diagnosed in the morning just hope its a cheap fix

  6. #6
    Regular Member glenboy's Avatar
    Join Date
    Jul 2007
    Location
    Sunny Dartmoor
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Good luck m8.........

  7. #7
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP1

    Engine : 1.9 CDTi 150

    Year : 2007

    Mileage : 66000

    Default

    Sounds like the 3rd injector, if like you say its not been changed.

  8. #8
    Regular Member vanquis1979's Avatar
    Join Date
    Mar 2008
    Location
    gainsborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Dan_BlackSRi View Post
    Sounds like the 3rd injector, if like you say its not been changed.
    would it make the car run like its on on 3 cylinders? dan and lacking power

  9. #9
    Regular Member
    Join Date
    Mar 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    mine had similar symptoms - the RAC towed it away yesterday saying it was a suspected blockagein the exhaust system - i've already had the injector wiring and egr valve done so it's not them......

  10. #10
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP1

    Engine : 1.9 CDTi 150

    Year : 2007

    Mileage : 66000

    Default

    Quote Originally Posted by vanquis1979 View Post
    would it make the car run like its on on 3 cylinders? dan and lacking power
    Yeah for sure, as it won't be powering the injector the same and will make the same difference as removing a plug lead off a petrol.

    Its only about £14 for the field kit and takes about 1hr to do properly.

    Remove the 3rd injector plug, spray some contact cleaner in the plug and then connect/disconnect a few times and see if that helps - if it does then its that.

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. urgent help needed.
    By adierolfe in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 25th June 2012, 09:53
  2. URGENT HELP: Zafira 2003 1.8XE poor running issue, not idling
    By merikiito in forum Engine & Drivetrain
    Replies: 25
    Last Post: 17th May 2012, 17:34
  3. urgent help needed?
    By webber446 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 11th January 2012, 14:30
  4. urgent help needed!!!!!!!!!!
    By johnnyg in forum Electrical & ICE (including SatNav)
    Replies: 11
    Last Post: 5th July 2008, 14:29
  5. urgent help needed
    By LISAJANE0410 in forum Suspension, Wheels & Brakes
    Replies: 11
    Last Post: 29th June 2008, 15:21

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •