User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: never needed serious help before......

  1. #1
    Regular Member
    Join Date
    Feb 2008
    Location
    norn iron
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default never needed serious help before......

    my 2.2 direct (z22yh) has started being sick

    has been driving perfect for the last two years that i have had the car (2005 with 45000 miles) but today she wont rev, only if you hold the throttle down for a long time she eventually picks up.

    on the road though, the car will barely rev above 1000rpm

    there are no lights on the dash, do you need a light to have a fault code?

    in my heart im preparing myself for hp pump failure but as there is no light on the dash im in hope of something lesss serious

  2. #2
    Regular Member
    Join Date
    Feb 2008
    Location
    norn iron
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    does any one know if the air flow meter can be cleaned?

  3. #3
    Full Member gibbon7000's Avatar
    Join Date
    Dec 2008
    Location
    lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It could be the accelerator peddle. They are electronic on the vec's. Also as you've already said it could be the HP fuel pump. It probably is the latter but its worth baring the peddle in mind

    My other car. 1972 1641cc slammed beetle. On the road finally!!

  4. #4
    Regular Member
    Join Date
    Feb 2008
    Location
    norn iron
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers for your input mate, will take off the intake and see if my butterfly is moving.

    does any one know what faults do not show any dash lights,

    just took off and cleaned my egr, no differance

    took plugs out and were really sooty even though they were replaced only three months ago, cleaned them but no differance

  5. #5
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    The butterfly should do a self test when you turn on the ignition mate. Take the intake off, get someone to turn the ignition on while you watch the butterfly, it should do a cycle (open close). does sound like the HPP or reg mate, as the rear pump will still be getting fuel up to the injectors but only at a very weak pressure.

  6. #6
    Regular Member
    Join Date
    Feb 2008
    Location
    norn iron
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers rushy, i knew you would be about somewhere,

    funny though, i thought it would have been the high revs that would be looking more pressure?

    do the two faults you mention throw up a light on the dash? i have none showing?

  7. #7
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by deg View Post
    do the two faults you mention throw up a light on the dash? i have none showing?
    It should put the car/spanner light on. If it is the fuel pump, then the fault code is P1191

  8. #8
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    With no load (in neutral) it will only take a very small amount of fuel to get it to rev up. Its when its under load that it needs all that fuel. I bet you could red line any engine with just a little throttle but under load its foot to the floor.

  9. #9
    Regular Member
    Join Date
    Feb 2008
    Location
    norn iron
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    right enough makes sense when you put it that way

    still unsure though as there are no lights, would the dealer still be able to find whats wrong with no fault lights on

  10. #10
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    A good mechanic would mate, but as you know VX tend to use muppets LOL. There are some good ones though, Benny's your man to speak to re the YH, he's one of the good ones.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Amp help needed
    By minimission83 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 5th March 2012, 22:17
  2. help needed
    By sebadee in forum Engine & Drivetrain
    Replies: 4
    Last Post: 21st January 2011, 19:57
  3. Help needed!!
    By seannygoat in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 26th December 2010, 17:23
  4. Help Needed
    By Andie-100 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 19th December 2010, 21:51
  5. How To Needed........
    By spennny in forum The 'Off Topic' room
    Replies: 6
    Last Post: 17th July 2009, 14:17

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •