User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Oil leak on 2.0T

  1. #1
    Regular Member
    Join Date
    Jan 2007
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Oil leak on 2.0T

    I noticed my oil light come on and i topped up to the maximum and then about 500 miles later, the light was back on. I checked, and it was down at minimum again.

    I've noticed the car is dribbling a few drops of oil onto the drive. The leak seems to be reasonably inline with the centre of front wheels and is over the exhuast (incidentally dribbling onto it and producing a bacon frazzles-esque smell!).

    Any idea on what might be causing this leak? I don't want it to worsen and at £15 per litre, I don't want to keep feeding it's oil habit!

    Any thoughts would be greatly appreciated.

    Best regards,

    Phil

  2. #2
    Full Member gibbon7000's Avatar
    Join Date
    Dec 2008
    Location
    lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you checked the obvisous. i.e the sump plug

    My other car. 1972 1641cc slammed beetle. On the road finally!!

  3. #3
    Regular Member
    Join Date
    Jan 2007
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've just tried to find it, unsuccessfully. I have noticed that it seems to be dripping off the main exhuast section. It also started after a recent service come to think of it.

  4. #4
    Regular Member jonnybravo's Avatar
    Join Date
    Jul 2009
    Location
    barnsley,yorkshire,GB
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum


    Engine : 20 Dti


    Default

    check oil filter housing,and rocker cover seal

  5. #5
    Regular Member
    Join Date
    Jan 2007
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the tips, I'll have to chock it up to view underneath. Rocker cover I should be ok with, that was the cause of the leak on my Vectra B

  6. #6
    Regular Member brifen's Avatar
    Join Date
    Nov 2008
    Location
    Fareham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Signum 2.0 DTI (Irmscher)

    Trim : Elegance

    Engine : 2.0 DTI 100 bhp

    Year : 2003

    Default

    Quote Originally Posted by phil79 View Post
    Thanks for the tips, I'll have to chock it up to view underneath. Rocker cover I should be ok with, that was the cause of the leak on my Vectra B
    How did you get on?

    Did you check here: Oil Filter housing, should be done up tight! Not overtight though. No oil should come out. If the area is oily then clean, take for a drive and check again.



    Also check here: Oil Drain Plug - Again should be tight but not over tight and no oil should be dripping out.



    Hope this helps you slightly, alternatively take it back to the place you had it serviced and tell them it's been using loads of oil since they serviced it. I'm sure they'll check it over and rectify the problem if it's due to a servicing error (Filter Housing or Drain Plug loose!).

    Bri.

  7. #7
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Turbo? That's right above the down pipe.

  8. #8
    Regular Member
    Join Date
    Jan 2007
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks Brifen, that's ever so helpful. It's not the oil filter, I've also taken the plastic engine cover off and I can't see anything from the rocker cover gasket. I've rather foolishly not been able to get to the sump plug as I've been unable to get the car up on ramps.

    Had a look round the turbo rushy and can't see any oil leaks anywhere. I'm just hoping it's nothing major!

    I'm taking it back to where it was serviced Thursday so fingers crossed it'll be something straighforward. I do recall when I bought it actually there was some oil leak which they fixed, possibly the oil sensor?

  9. #9
    Regular Member brifen's Avatar
    Join Date
    Nov 2008
    Location
    Fareham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Signum 2.0 DTI (Irmscher)

    Trim : Elegance

    Engine : 2.0 DTI 100 bhp

    Year : 2003

    Default

    Hope you get it sorted Phil, The concern would have been if oil was from the turbo area, I think it should be something simple and hopefully one of them free fixes and the sump plug just needs a tweek!

    If it is due to the sump plug and therefore a servicing error then you want to get them to supply you with some oil (5Ltr of good stuff). Alternatively see if you can get a free mid service oil and filter change once you've done a few thousand miles. I don't think that's unreasonable?

    Bri.

  10. #10
    Regular Member
    Join Date
    Jan 2007
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks very much Brifen. Well, someone mentioned a seal at the end of the crank as being a possibility, so I guess rather the turbo than that! However, there's no loss in performance or anything and the leak is slight (250 miles today, negligable drop in oil level today) so fingers crossed it's something simple. There's certainly nothing spurting out and it is a gradual leak which seems unaffected by how hard you push the car (I'd sort of expect something 'mechanical' to happen more the more you rag it!)

    Yeah, I've forked out £30 in oil over the past two days (one for top up, one for spare) so that wouldn't be a bad plan.

    Thanks again and I'll keep you posted!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil leak 150 cdti oil leak help
    By sr_fly in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 14th July 2011, 20:46
  2. Oil Leak
    By Tam80 in forum Engine & Drivetrain
    Replies: 12
    Last Post: 17th January 2011, 13:41
  3. Oil leak
    By Rich2.2 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 19th May 2010, 20:31
  4. Leak, front end creak, refurb, bent locking wheel key and another leak =(
    By nick-v2.2 in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 15th February 2010, 19:58
  5. 3.2 oil leak from?
    By megaderek in forum Engine & Drivetrain
    Replies: 3
    Last Post: 29th September 2009, 22:45

Visitors found this page by searching for:

oil leak vecta c

vauxhall signum 2.0 t engine

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •