User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: help needed

  1. #1
    Regular Member Matt&Jemz's Avatar
    Join Date
    Dec 2008
    Location
    CORNWALL
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default help needed

    we have a bit of a problem with our signum and need some help pls guys


    we have a signum turbo petrol net engine
    it has the bsr downpipe bsr ppc and stainless exhaust and airbox mods
    after pv we put a sports filter on just in the normal air box
    after a week or so the engine mangement light came on saying there was a fault with the M.A.F so we took it all apart and cleaned it all up and put the standard filter back in all fine again

    for a week or so the same problem happened lack of power in first and second some times engine light on sometimes not so we disconect the battery it cures it for a while but comes back we have taken the bsr ppc off and put it back on and it still comes back with same problem so is it the M.A.F sensor ?
    a problem with the airbox mod ?
    is it now sucking in to much air and the car cant cope ?

    help guys its £130 or so for a M.A.F sensor dont wanna pay that if we dont have to

    any help welcomed

  2. #2
    Regular Member
    Join Date
    Aug 2009
    Location
    Havant
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    how old is the car? would u be expecting a maf to be nearing the end of its life? any )erformance enhancing' mods u make to the air intake system are likely to shorten MAF life expectancy as they will allow more crap and more water to get through the maf and into the engine. first port of call is cleaning the maf and connectors. use isopropyl alcohol - available from the likes of maplins in a aerosol. this is an alcohol based cleaner that blasts dirt away before completely evaporating. ideal for cleaning sensitive electronic that u darent touch. eg maf sensors!

    hope this helps...

  3. #3
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    is there anyone close to you that can do a "donor swap" for a few hours to dispell or confirm the maf sensor as being faulty ?

    i'd lend you mine but your so far away

    0-Large smile ......every time it's driven

  4. #4
    Regular Member Matt&Jemz's Avatar
    Join Date
    Dec 2008
    Location
    CORNWALL
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks guys.

    Car is an 04 plate and the mods were done end of May/beginning of June and the filter a week after PV.

    I'm convinced it's the airbox rather than the sensor. But we're trying to put the car back to standard rather bit by bit first to try and establish why the hell it's gone like this. It only does it on long journeys though so borrowing someone's isn't really an option. Like Matt said sometime there is no power in first and second either and won't even hit 30mph in those gears!! Great when it can be intermitent and the engine management light isn't on and you pull out onto the A30 in front of a coach But yeah sometimes the engine management light comes on but drives fine ish, just sometimes feel the car judder but has all power, sometimes it does this and also has no power in first and second but fine in all others and sometimes the engine management light doen't come on at all but has no power in first or second.

    Babby we tried WD-40 on it, it worked on our Cavalier GSi!!

  5. #5
    Regular Member Super T's Avatar
    Join Date
    May 2007
    Location
    On the Levels
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As said clean sensor and replace filter with standard paper filter! you can use mine if Jemz wants to pop over one evening in the week and pick it up.

  6. #6
    Regular Member Matt&Jemz's Avatar
    Join Date
    Dec 2008
    Location
    CORNWALL
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ok thanks tony may give you a bell sunday after meet if your around

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Amp help needed
    By minimission83 in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 5th March 2012, 22:17
  2. help needed
    By sebadee in forum Engine & Drivetrain
    Replies: 4
    Last Post: 21st January 2011, 19:57
  3. Help needed!!
    By seannygoat in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 26th December 2010, 17:23
  4. Help Needed
    By Andie-100 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 19th December 2010, 21:51
  5. How To Needed........
    By spennny in forum The 'Off Topic' room
    Replies: 6
    Last Post: 17th July 2009, 14:17

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •