User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: possible flat spot?

  1. #1
    Regular Member
    Join Date
    Feb 2009
    Location
    jilava
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default possible flat spot?

    Hi, I'm trying to figure out if this si normal operation and I need your opinions.

    I have a 2004 vec 150ps that takes about 2-3 secs to reach 2200 rpm from 1750 rpm and then starts to pull, probabily because the turbo kicks in. This is in 3rd gear, in 2nd it takes a bit less, about 2 secs.

    I did clean the egr valve and actuator guided by the how-to here on the forum (very helpful) about 2 months ago because the car had a hesitation problem around 2000rpm, and I did got rid of it. But I need some opinions on the possible flat spot problem.

  2. #2
    Regular Member
    Join Date
    Feb 2009
    Location
    jilava
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The way I tested: keep the car at 1750 rpm in 3rd for a few seconds then boot it.

  3. #3
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP NAV

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    Maybe you need to check your swirl flaps / control bar... have a search on the forum, as there are a few threads that go into this in detail.

  4. #4
    Regular Member
    Join Date
    Feb 2009
    Location
    jilava
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Dan, I did check with an OP_COM that has a swirl valve test, the rod seems OK, I posted 2 pics with the rod and position of the flaps in this thread http://www.vectra-c.com/forum/showth...ht=swirl+valve

    Does it look OK?

  5. #5
    Regular Member Dan_BlackSRi's Avatar
    Join Date
    Aug 2008
    Location
    Lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi

    Trim : XP NAV

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    Quote Originally Posted by andreitone View Post
    Dan, I did check with an OP_COM that has a swirl valve test, the rod seems OK, I posted 2 pics with the rod and position of the flaps in this thread http://www.vectra-c.com/forum/showth...ht=swirl+valve

    Does it look OK?
    Didn't see that mate, yeah that looks fine (very clean too) so it looks as though the Swirls are ok. Could be a faulty EGR, the clean doesn't always work mate.

  6. #6
    Regular Member
    Join Date
    Feb 2009
    Location
    jilava
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    could it have something to do with the boost sensor? I can try and clean it... rather than buy a new egr valve..., is there any way of knowing for sure if the egr is bad?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Flat spot :(
    By marc vectra sri in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 13th August 2012, 19:06
  2. Flat spot
    By marc vectra sri in forum The 'Off Topic' room
    Replies: 1
    Last Post: 12th August 2012, 19:38
  3. flat spot but different
    By Derek Mc in forum Engine & Drivetrain
    Replies: 3
    Last Post: 28th July 2012, 11:40
  4. Flat spot!
    By bigknill in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 24th July 2009, 09:43
  5. flat spot
    By surreyl31 in forum Petrol Engine related
    Replies: 6
    Last Post: 16th July 2007, 18:41

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •