User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Powersteering has stopped??

  1. #1
    Regular Member
    Join Date
    Apr 2009
    Location
    australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Powersteering has stopped??

    Hi guys,
    New to this site and am really in need of some sound advice.
    Okay 1 yr ago my powersteering just stopped. Not sure why there were no signs. Then 2 mnths later it started to work again and has been for 10mnths.
    Would anyone have any idea as to why this is happenning. There is plenty of fluid and when it starts agin it works fine. I had the vectra into the dealers for a service before it came back and they said the pump was shot. Well its been fine for 10mnths I would say another money grab by them.
    If anyone has had this happen and know what to do please let me know. My car is a 2003 vectra cdxi 3.2.
    Cheers Greg

  2. #2
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    these pumps are electric, and has resisters inside them, so it sound like you will need a new pump

  3. #3
    Regular Member
    Join Date
    Feb 2009
    Location
    jilava
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This happend to my father's citroen C3 once, the front tyres pressure was too low, after he inflated them the power steering worked again. I'm not saying this is the case with yours, but thought it might be helpful...

  4. #4
    Regular Member
    Join Date
    Sep 2007
    Location
    Sweden
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Happend me too. It ended with a replacement of the pump (Vectra C '04). It was a quite easy job, took me 1 hour. I paied about £100 for a used pump. I opened the old one and found what has caused the problem: the location of the pump makes it pretty exposed to (salty) water and if the rubber seal that is protecting the PCB (where all eletric components are) will get damaged you'll sooner or later get water into it and that will ruin the PCB. You can see that since there is a lot of green stuff around and into the PCB, same stuff you can find in a battery compartment if the battery has been left too long.

  5. #5
    Regular Member Tadpole's Avatar
    Join Date
    Dec 2008
    Location
    'I haven’t lost my marbles, they’re in a bag somewhere? .. '
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by nizzehult View Post
    Happend me too. It ended with a replacement of the pump (Vectra C '04). It was a quite easy job, took me 1 hour. I paied about £100 for a used pump. I opened the old one and found what has caused the problem: the location of the pump makes it pretty exposed to (salty) water and if the rubber seal that is protecting the PCB (where all eletric components are) will get damaged you'll sooner or later get water into it and that will ruin the PCB. You can see that since there is a lot of green stuff around and into the PCB, same stuff you can find in a battery compartment if the battery has been left too long.
    Good information it's a stupid place to have it imo but it's there so we must expect these problems .......................

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Powersteering pump wiring
    By MARKPRIOR in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 25th March 2011, 13:56
  2. Powersteering fluid on 3.2
    By jamesr in forum Engine & Drivetrain
    Replies: 4
    Last Post: 11th February 2011, 18:35
  3. powersteering help
    By sean-s in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 4th February 2011, 17:11
  4. Powersteering keeps stopping
    By kiwiboy in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 9th August 2009, 00:11
  5. powersteering
    By steeb82 in forum Vectra C / Signum Car Chat
    Replies: 15
    Last Post: 27th November 2008, 13:38

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •