User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Help 2.2DTi

  1. #1
    Regular Member
    Join Date
    Jul 2005
    Location
    South London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Help 2.2DTi

    Hi I have just migrated from the Vectra Sports Forum as this forum appears to be dedicated to the Vectra C.

    Also I have a problem.

    Firstly, is it possible to read fault codes on the C as it was on the B?

    Now the problem. I was driving up the road just now and the engine electronics control indicator came on. The car with a spanner through it. The engine dropped into limp home mode. Stopping the car and restarting everything was fine, for a few miles then the same thing happened. Stopping and restarting again all was fine. But the cycle repeats.

    Has anyone any ideas please before I entrust the work to a Vauxhall dealer.

    Thanks for replies.

  2. #2
    Ex Vec-C Admin & Founder GARY3306's Avatar
    Join Date
    Jun 2005
    Location
    Ashington, Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Don't know what your mileage is mate or when you last had a fuel filter changed (presuming you have a diesel that is), because before charging down to the dealer, it could be simply water in the fuel filter, because that can put your light on as well. Drain the filter via the little plug on the bottom. If you still get the problem then go to the diddler... I mean dealer. If it's a petrol, dealer job. Welcome to the site by the way.
    [SIGPIC]VX<font color=Red>R</font> with added Courtenay <img src=https://www.vectra-c.com/forum/images/smilies/biggrin.png border=0 alt= title=Big Grin class=inlineimg />

  3. #3
    Regular Member
    Join Date
    Jul 2005
    Location
    South London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi Gary3306

    Yes it is a diesel and the mileage is 14500.

    The fuel filter was drained of water about 5 days ago.

  4. #4
    Ex Vec-C Admin & Founder GARY3306's Avatar
    Join Date
    Jun 2005
    Location
    Ashington, Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by FRANKA
    Hi Gary3306

    Yes it is a diesel and the mileage is 14500.

    The fuel filter was drained of water about 5 days ago.
    In that case mate get the dealer to have a look. If anything is wrong engine management wise it will be warranty anyway.
    [SIGPIC]VX<font color=Red>R</font> with added Courtenay <img src=https://www.vectra-c.com/forum/images/smilies/biggrin.png border=0 alt= title=Big Grin class=inlineimg />

  5. #5
    Regular Member MJED's Avatar
    Join Date
    Jul 2005
    Location
    Shropshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had a 2.2DTi and took it back to the Dealer FIVE times for the same thing - Twice they found a split pressure return pipe (what ever that was!) and the other Three they found nothing. In the end I took the easy option (and the most expensive) and swapped it for a V6 CDTI.

    Hope you have better luck!.

    Mark

  6. #6
    Regular Member
    Join Date
    Jul 2005
    Location
    South London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Well pleased

    I found the problem. The hose between the intercooler and the turbo had blown.

    Found this last Saturday week just as I was about to depart for Cornwall.
    Was in the parts department first thing Monday morning for a new hose. None in stock and was told they had been on back order for ten days. Help! I then rang customer care at Vauxhall. They said the part would not be available for a further week.

    Now the good news. They said that under the termns of the warranty they have duty to keep you mobile. They contacted a dealer of my choice, told me to book the car in and they would provide a substitute car.

    I was provided with a 6 week old Elite estate.

    Have just got back from Cornwall and am picking up my car in the morning.

    O.K. the hose syhould not have blown after only 14000miles but the after service was superb.

  7. #7
    On a Sabbatical
    Join Date
    Jun 2005
    Location
    Failsworth, Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    That's good to hear. All too often we hear stories of nightmare dealers but never a good one. Glad you got sorted out mate.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.2Dti
    By Gazz in forum Diesel Engine related
    Replies: 7
    Last Post: 24th May 2011, 12:44
  2. Will this fit my 2.2dti
    By sberrow in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 5th May 2011, 20:25
  3. Eml 2.2dti
    By Gortreck in forum Engine & Drivetrain
    Replies: 3
    Last Post: 3rd March 2010, 20:23
  4. its not too bad for a std 2.2dti.............
    By david.aka.judas in forum Gallery
    Replies: 15
    Last Post: 16th March 2009, 08:58
  5. 2.2dti, not GM?
    By prm in forum Vectra C / Signum Car Chat
    Replies: 24
    Last Post: 20th June 2007, 00:32

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •