User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Temp Problem - Petrol Engine

  1. #1
    Regular Member
    Join Date
    Nov 2008
    Location
    Derbyshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Temp Problem - Petrol Engine

    I've done a few searches on this but all the threads I found were relating to diesel engines. My '07 1.8vvt SRi now takes an age for the temp gauge to move and it doesn't sit as high as normal. It used to sit bang on halfway at 90 but now never goes above 80 and is only just starting to creep up after my 10mile journey to work. I've booked it in at my local dealer but am now worried that they will say nothing is wrong and charge me for the privilege, I've checked all the fluid levels and everything is fine, there are also no other warning lights coming on. Is there anything I can check myself? It never really goes any further than the run to work so I will take it for a longer drive tonight...

  2. #2
    Regular Member yessof's Avatar
    Join Date
    Jan 2008
    Location
    west yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi had same problem on my 06 1800. Worse in winter, gauge didnt move until I'd driven for about 10 miles. Faulty thermostat. Managed to get it replaced on warranty.

  3. #3
    Regular Member JagRigger's Avatar
    Join Date
    Jun 2008
    Location
    Norfolk
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Certainly sounds like a thermostat stuck in the open position.

  4. #4
    Regular Member
    Join Date
    Nov 2008
    Location
    Derbyshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yeah I think you guys are right. When you get on an open bit of road, the temp actually drops!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. what should teh engine temp be in 1.9 150
    By kirky2k4 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 26th January 2011, 22:16
  2. engine temp
    By iasha in forum Engine & Drivetrain
    Replies: 1
    Last Post: 27th January 2010, 00:39
  3. engine temp.
    By Graeme01 in forum Engine & Drivetrain
    Replies: 8
    Last Post: 21st October 2009, 19:56
  4. Where is the coolant temp sensor/sender on a 3.2 Petrol?
    By marcdale in forum Engine & Drivetrain
    Replies: 1
    Last Post: 1st June 2009, 11:08
  5. temp problem
    By bigcraig in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 15th April 2007, 21:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •