User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: Oil Light

  1. #1
    Regular Member garvey's Avatar
    Join Date
    Feb 2008
    Location
    Co Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Oil Light

    My oil light has come on.I have checked the oil and its fine. I have been through a lot of deep puddles today.anyone any ideas

  2. #2
    VIP-Member brifen's Avatar
    Join Date
    Nov 2008
    Location
    Fareham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Signum 2.0 DTI (Irmscher)

    Trim : Elegance

    Engine : 2.0 DTI 100 bhp

    Year : 2003

    Default

    Quite strange, I've also got the 2.2 DTI engine and I have an annoying problem of the oil light. With mine if I sit at a steady 50mph in 5th gear (usualy flick on cruise control) in a set of long roadworks, after about 5 - 10min I will get the oil light come on. Thought it was just a one off when it happened but it happens almost like clockwork if sitting at a constant 50 for a while (wouldn't have the problem if it wasn't SPECS cameras).

    The fist time of course I pulled over straight away and checked oil level etc but all was fine. The oil light that comes on is not the red engine oil warning light but an oil symbol in the centre of info display (just as if a bulb had gone or door open etc...). On the other occations it happens I just keep going now and often stop at the next services so I can turn engine off and back on again to get rid of the oil light. Would like for it not to happen though.

    Bri.
    Today!! The new tomorrow, live the NOW!!

  3. #3
    Regular Member garvey's Avatar
    Join Date
    Feb 2008
    Location
    Co Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine is the red oil light I now believe it may be the oil pump failing.

  4. #4
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Didn't you have a similar problem with your last motor?

  5. #5
    Regular Member jonnybravo's Avatar
    Join Date
    Jul 2009
    Location
    barnsley,yorkshire,GB
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum


    Engine : 20 Dti


    Default

    HI bud
    you need to check oil pressure before you use car or you may distroy engine,with the milage you have it's possible mains and big ends are tired.you need an oil pressure clock for the test or fit a new switch and try again.at best it's the switch,at worst oil pump or worn mains and crank

  6. #6
    Regular Member garvey's Avatar
    Join Date
    Feb 2008
    Location
    Co Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by jonnybravo View Post
    HI bud
    you need to check oil pressure before you use car or you may distroy engine,with the milage you have it's possible mains and big ends are tired.you need an oil pressure clock for the test or fit a new switch and try again.at best it's the switch,at worst oil pump or worn mains and crank
    I got a brand new engine in november its now only done about 65,000. cheers i will get it checked tomorrow.

  7. #7
    Regular Member JET SINGH's Avatar
    Join Date
    Oct 2008
    Location
    NORTHAMPTON
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The same happened to my 06 1.8SRi a couple of weeks ago....went in for a service and i got them to look into it.
    They said it required a software update, which cost me an additional £40. This has sorted it and it hasnt appeared since!!

  8. #8
    Regular Member garvey's Avatar
    Join Date
    Feb 2008
    Location
    Co Durham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Good newschanged the oil sensor and no light

  9. #9
    Regular Member jonnybravo's Avatar
    Join Date
    Jul 2009
    Location
    barnsley,yorkshire,GB
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum


    Engine : 20 Dti


    Default

    good result

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Replies: 4
    Last Post: 18th August 2012, 08:58
  3. Replies: 17
    Last Post: 16th August 2012, 10:07
  4. No throttle, traction control light, engine management light
    By si260188 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 9th May 2010, 21:45
  5. Fitted rear light,illuminated sunvisors and map reading light
    By glenboy in forum Vectra C / Signum Car Chat
    Replies: 26
    Last Post: 30th March 2008, 10:51

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •