User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Newbie in need of help, PLEEEEEASE.

  1. #1
    New Member gavinthetazman's Avatar
    Join Date
    Jun 2009
    Location
    cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Newbie in need of help, PLEEEEEASE.

    Hi All, Im having trouble with my 52reg 1.8 16v Vectra club, my eml light keeps coming on and the code says P0170 and it also revs erratically when idle.
    I have a u480 hand held code reader and the code means: fuel trim malfunction bank 1. I have replaced the following to try and rectify the fault: Air flow meter, both lambda sensors, coil pack (as advised by garage who had the car for 2 weeks). I had the ECU tested by ECUtesting.com and they found no faults with it.
    I have removed and cleaned the throttle body, rocker cover, and breather hoses and added some injector cleaner to the fuel to clean them out. The car seems to be more responsive after all this but it still idles irratically and the eml light came back on stating the same code.

    PLEASE CAN ANYBODY THROW ANY LIGHT ON WHAT TO TRY NEXT, AS MY BANK BALANCE IS DWINDELING FAST.


    Thanks
    Gavin.

  2. #2
    New Member gavinthetazman's Avatar
    Join Date
    Jun 2009
    Location
    cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Somebody pleeeease help im desperate and dont really wont to take it the stealers. Help pleeease.

  3. #3
    Full Member paul.sessions's Avatar
    Join Date
    May 2009
    Location
    leighton buzzard
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    have you tried cleaning the egr valve??

  4. #4
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    213 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    is the Airflow meter around the correct way??? check the direction of the airflow on the unit (theres an arrow on it)... this could cause that problem
    Last edited by plasma; 4th July 2009 at 23:37.
    Plasma's Tech2 services are now partially open and able to provide services



    Come Join our new forum Insignia Owners.com for all your Insignia chat and needs

  5. #5
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    A quick Google brings up loads of faults mate, from blockage in the intake, to engine temp reading wrong, causing the fueling to increase.

  6. #6
    Regular Member Vectra Dan's Avatar
    Join Date
    Jun 2009
    Location
    winsford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi mate i just bin on my autodata and i found the error code which u have a problem with. This is what my autodata came up with buddy


  7. #7
    Regular Member Vectra Dan's Avatar
    Join Date
    Jun 2009
    Location
    winsford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    let me know whether that help u or if there anythin else i can do for ya mate


    btw is it a vectra b or c

  8. #8
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Quote Originally Posted by Vectra Dan View Post
    let me know whether that help u or if there anythin else i can do for ya mate


    btw is it a vectra b or c

    A 52 plate Vec C will have the Z18XE engine anyway as would the B.

  9. #9
    New Member gavinthetazman's Avatar
    Join Date
    Jun 2009
    Location
    cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    PLASMA: The airflow meter is fitted in the correct direction.
    RUSHY: I have been told about the temp switch but as far as I can tell it works ok (reads around 90 when warm), should I change it as a matter of precausion as its not to expensive to buy?
    VECTRADAN: I have autodata myself and have tried and tested all the components listed but still has the fault, which is why I have no idea what else could be causing the fault, other than changing the temp switch. Its a Vectra C by the way.
    Thanks everyone for your help and advice, I will keep this post updated to let you all know how I get on.

  10. #10
    Regular Member Sean-2.2Direct's Avatar
    Join Date
    Apr 2008
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by gavinthetazman View Post
    PLASMA: The airflow meter is fitted in the correct direction.
    RUSHY: I have been told about the temp switch but as far as I can tell it works ok (reads around 90 when warm), should I change it as a matter of precausion as its not to expensive to buy?
    VECTRADAN: I have autodata myself and have tried and tested all the components listed but still has the fault, which is why I have no idea what else could be causing the fault, other than changing the temp switch. Its a Vectra C by the way.
    Thanks everyone for your help and advice, I will keep this post updated to let you all know how I get on.

    Mate do me a favour Andys done the same thing and we unplugged the MAF and hey presto it worked fine we just give it a clean and so far no problems.

    Just unplug the cable from the maf and see if it goes back to normal let me know

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. newbie asking newbie question :-)
    By gavatron in forum Engine & Drivetrain
    Replies: 13
    Last Post: 6th February 2012, 10:39
  2. Newbie
    By bigjjfaetheyy in forum Introduce yourself.
    Replies: 5
    Last Post: 2nd October 2009, 08:57
  3. Newbie.
    By Martinlw in forum Introduce yourself.
    Replies: 3
    Last Post: 1st October 2009, 05:46
  4. Newbie
    By VectraAlan1888 in forum Introduce yourself.
    Replies: 9
    Last Post: 16th September 2009, 19:02
  5. newbie.
    By signum@37 in forum Introduce yourself.
    Replies: 15
    Last Post: 3rd August 2009, 12:25

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •