User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: maybe turbo or ...!!!?

  1. #1
    Regular Member rioni's Avatar
    Join Date
    Jun 2008
    Location
    london
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default maybe turbo or ...!!!?

    cheers to all, so i have a problem , i was driving in the morning the car an sudenly BANG from engine , now i have no turbo no spanner light no black smoke just no turbo can somewone help me about this . is turbo or something else......


    cheers

  2. #2
    Regular Member rioni's Avatar
    Join Date
    Jun 2008
    Location
    london
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Unhappy

    anybody..........!!!!!! heeelp

  3. #3
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTI 150

    Trim : Design

    Engine : Z19DTH

    Year : 2005

    Default

    Check the rubber pipes that run to the turbo, its not uncommon for 1 to split.
    This will cause no boost, without a warning lamp, pipe costs about £18 from Vx.
    Hope its this.

  4. #4
    Regular Member rioni's Avatar
    Join Date
    Jun 2008
    Location
    london
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thnx you mate, i would check today as soon as possible....cheers

  5. #5
    Vec-C Facebook Admin thegoldenbullet's Avatar
    Join Date
    Mar 2007
    Location
    Grimsby, Lincs.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i had a similar situation with my car, same sound and same symptoms but with black smoke. That was a pipe from the intercooler!

  6. #6
    Regular Member rioni's Avatar
    Join Date
    Jun 2008
    Location
    london
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i hope

  7. #7
    Regular Member brad69bj's Avatar
    Join Date
    Jun 2009
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If it went bang, or loud pop, when you were accelerating hard it will probably be the Intercooler pipe! If it was a Vacuum pipe there wudnt have been a bang, or a loud pop so to speak, it would just lose power.

  8. #8
    Regular Member rioni's Avatar
    Join Date
    Jun 2008
    Location
    london
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hey i've been to service and they told me a turbocharger gone so quoted 500£ for a newone and 400£ to repair the old so i went for the new one cheers guys and thnx for your help...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 19
    Last Post: 6th September 2014, 13:54
  2. Turbo Technics Hybrid turbo details.
    By nutron in forum Diesel Engine related
    Replies: 13
    Last Post: 28th February 2011, 22:57
  3. TD04L14T turbo for Z20NET (2.0 turbo)
    By Caveman_nige in forum Parts for sale
    Replies: 3
    Last Post: 10th October 2010, 13:23
  4. Turbo Help
    By CDTi-SRi-Matt in forum Engine & Drivetrain
    Replies: 5
    Last Post: 12th February 2010, 11:42
  5. is it possible to change 2.0 dti turbo to 2.2dti turbo
    By EURO G in forum Engine & Drivetrain
    Replies: 17
    Last Post: 22nd October 2008, 07:35

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •