User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: problem with my vectra c

  1. #1
    Regular Member the fisherman's Avatar
    Join Date
    Feb 2009
    Location
    manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default problem with my vectra c

    when driving and i hit a hole in road or where a grid is my car seems to jump left a little,anyone got any ideas what it could be?as really anoying me now

  2. #2
    Regular Member bigcarman79's Avatar
    Join Date
    Jan 2008
    Location
    Pontefract
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by the fisherman View Post
    when driving and i hit a hole in road or where a grid is my car seems to jump left a little,anyone got any ideas what it could be?as really anoying me now
    Check the bottom arms mate, very common wear 'n' tear componant!

  3. #3
    Regular Member the fisherman's Avatar
    Join Date
    Feb 2009
    Location
    manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    is that the part that looks like a boomarang?

  4. #4
    Regular Member bigcarman79's Avatar
    Join Date
    Jan 2008
    Location
    Pontefract
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by the fisherman View Post
    is that the part that looks like a boomarang?
    lol...Yes mate, could also be the bottom ball joint but thet tend to be noisy when worn.

  5. #5
    Regular Member the fisherman's Avatar
    Join Date
    Feb 2009
    Location
    manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it only jumps to left when i hit a bump

  6. #6
    Regular Member
    Join Date
    Apr 2009
    Location
    shrewsbury
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Had exactly the same with my vectra c recently. As well as the jumping to the left i also had a thumping noise from the back end.
    As said check your trailing arms(boomerangs). The easy way to do this is to park car somewhere flatish,dont jack car up, and grab hold of a rear wheel top and bottom and see if it will rock, not left to right but top to bottom. If either do then you definately need new arms before anything else. If you do need to change either arm the 'How To' and associated updates are really useful.
    This also gives you an opportunity to check your springs for cracks/breaks as they need to be removed to change arms.
    The rear drivers side was the only one that rocked on mine so only needed to replace that one.
    BUT the thumping noise was still present but not as noticeable and the car still jumped. If this still happens then the next step, assuming your springs are ok, is to change the rear shocks.
    B4's from Euro-car parts are £65 a pair delivered, they are all the same no matter if you have an SRi or not. Took 45mins to do both sides and the thumping noise and more importantly the jumping to the left has stopped.

    Good luck and dont hesitate to ask if more advice is needed,

    Regards, Mark.

  7. #7
    Regular Member the fisherman's Avatar
    Join Date
    Feb 2009
    Location
    manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i too have that sort of thumping noise and its annoying escpecially when you put loads of money into the car and its still got work to be done.

    i have new springs put on just about 1 month ago lowered it to 45 front and 40 back or the other way round carn remember now lol so i no springs areok as theyre bran new.

    so you think its either my suspension arms or shocks do you mate?

    so once you changed your shocks he thumping and the jumping stopped did itm8???
    Last edited by the fisherman; 17th June 2009 at 10:37.

  8. #8
    Regular Member zazaszazas's Avatar
    Join Date
    Jan 2009
    Location
    Cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by the fisherman View Post
    when driving and i hit a hole in road or where a grid is my car seems to jump left a little,anyone got any ideas what it could be?as really anoying me now
    i've had exactly the same problem..1st i've changed the lower control arms(no luck)changed the springs and shocks(no luck) changed the drop links (no luck) and finally i;ve changed the arb bushes and heeeeyyy problem solved.

  9. #9
    Regular Member the fisherman's Avatar
    Join Date
    Feb 2009
    Location
    manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    arb bushes ????????what are them and did you also have the thumping noise aswell as the jumping

  10. #10
    Regular Member zazaszazas's Avatar
    Join Date
    Jan 2009
    Location
    Cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by the fisherman View Post
    arb bushes ????????what are them and did you also have the thumping noise aswell as the jumping
    yep i've had exactly the same problems m8...arb=arb bushes (worn out )

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra wiper problem - any advice appreciated - Vectra C
    By newbreed in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 13th May 2011, 20:57
  2. Vectra 1.8 LS, big problem?
    By Mattyreid9 in forum Engine & Drivetrain
    Replies: 25
    Last Post: 5th October 2010, 12:28
  3. air con problem vectra c
    By stevenrwaller in forum Electrical & ICE (including SatNav)
    Replies: 18
    Last Post: 20th July 2010, 10:03
  4. vectra c problem help
    By beemerboy31 in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 29th January 2009, 23:39
  5. Problem...? Vectra SXI...problem with starting after filling with fuel?
    By doozer in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 8th November 2008, 09:40

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •