User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37

Thread: Engine cutting out!! Exhaust emissions warning light! Help!

  1. #1
    New Member
    Join Date
    Dec 2007
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Engine cutting out!! Exhaust emissions warning light! Help!

    Hi all,

    A couple of days ago the exhaust emissions warning light came on while driving (constant not flashing) , instantly followed by the rev counter dropping with complete loss of power (including power steering) and then the red battery symbol came on. Coasted to the side of road and tried to re-start but nothing happened (starter motor not even turning over) so waited about 30seconds and tried again. This time it starts fine but the exhaust emissions warning light stays on and I drive home without any problems.

    The next day it starts fine again and no warning light but...

    Yesterday the exact same thing happened again TWICE in one (short) journey and again today. I usually have to wait around 30secs to a minute before re-starting. The warning light seems to stay on for next couple of re-starts but will eventually go away.

    Will be booking in to the garage as soon as I can but was hoping that someone could shed some light on why this might be happening??

    Thanks in advance

    Oh its a 52 plate 2.2 petrol if thats any help. Cheers

  2. #2
    Regular Member
    Join Date
    Feb 2008
    Location
    Gävle, Sweden
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As it's a petrol, I suspect the high pressure fuel pump. I had mine replaced last week...

  3. #3
    Regular Member Sean-2.2Direct's Avatar
    Join Date
    Apr 2008
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by stryker99 View Post
    As it's a petrol, I suspect the high pressure fuel pump. I had mine replaced last week...

    Hi mate

    Only 04 or 54 onwards have a high pressure fuel pump his engine is a Z22SE so his does not have one the previous model

    Ours is a Z22YH which is Direct injection the one with the High pressure fuel pump

  4. #4
    Regular Member Sean-2.2Direct's Avatar
    Join Date
    Apr 2008
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by jde1 View Post
    Hi all,

    A couple of days ago the exhaust emissions warning light came on while driving (constant not flashing) , instantly followed by the rev counter dropping with complete loss of power (including power steering) and then the red battery symbol came on. Coasted to the side of road and tried to re-start but nothing happened (starter motor not even turning over) so waited about 30seconds and tried again. This time it starts fine but the exhaust emissions warning light stays on and I drive home without any problems.

    The next day it starts fine again and no warning light but...

    Yesterday the exact same thing happened again TWICE in one (short) journey and again today. I usually have to wait around 30secs to a minute before re-starting. The warning light seems to stay on for next couple of re-starts but will eventually go away.

    Will be booking in to the garage as soon as I can but was hoping that someone could shed some light on why this might be happening??

    Thanks in advance

    Oh its a 52 plate 2.2 petrol if thats any help. Cheers
    Hi mate Rushy might know more about this im sure he will be on in a bit hes somthing of a expert on your engine

  5. #5
    New Member
    Join Date
    Dec 2007
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for the reply. I had it in the garage last week and they couldn't find any fault codes! Sod's law that on the way to the garage it was fine and no warning lights were on so when they plugged the machine in it told them nothing. Got home from the garage fine as well. But last night it happened again five times in a row!! Had to get breakdown truck out to carry me home!

    The breakdown guy mentioned it might be the lamda sensor but not sure. It's going back to the garage today.

  6. #6
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Sean-2.2Direct View Post
    Hi mate

    Only 04 or 54 onwards have a high pressure fuel pump his engine is a Z22SE so his does not have one the previous model

    Ours is a Z22YH which is Direct injection the one with the High pressure fuel pump
    Unless its a signum which all of the 2.2's were directs
    Now I need a turbo to keep up!

  7. #7
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    If it has a habbit of cutting out at idle I would suggest egr valve needs cleaned. That was the same symptoms on our 1.6 corsa, emmissions light was on, and car would judder at idle and occasionally cut out.

    Gazza4

  8. #8
    New Member
    Join Date
    Dec 2007
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I also had the judder problem and it would 'hunt' between 5000 and 10000 revs at times but while it was in last week it had a service and they also cleaned out the throttle body and breathers (whatever they are!) because they were carbonised apparently. It now idles at a solid 7000ish with no judder. Seems a bit more responsive too when its not dying on me!

    It's a 2.2i 16v Elite if that makes any difference.

  9. #9
    Full Member
    Join Date
    Jun 2007
    Location
    N/A
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    7 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Golf 7

    Trim : GTD

    Engine : 2.0 TDI 184PS

    Year : 2014

    Mileage : 40000

    Default

    The emissions light is could also be indicating a catalytic convertor issue.

    Only way to check for this is to have an emission check.


    Gazza4

  10. #10
    New Member
    Join Date
    Dec 2007
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    So... just got a call from the garage and apparently the error code is p0601 which means an internal ECU fault! They are now asking for £579 for a new ECU unit!!! Grrrr!!

    Any ideas of how I can avoid this would be greatly appreciated??

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Emissions warning light on
    By peterb11 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 18th March 2011, 17:03
  2. Emissions Warning Light
    By fifesri in forum Engine & Drivetrain
    Replies: 15
    Last Post: 14th September 2010, 20:58
  3. Emissions Warning Light
    By Electricdave in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 2nd September 2010, 21:12
  4. Engine/Emissions warning light
    By MultiDropper in forum Vectra C / Signum Car Chat
    Replies: 18
    Last Post: 19th March 2010, 14:23
  5. Replies: 1
    Last Post: 1st September 2007, 12:17

Visitors found this page by searching for:

vectra exhaust cuts out engine

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •