User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: engine light problem

  1. #1
    New Member neil9629's Avatar
    Join Date
    May 2009
    Location
    newcastle-upon-tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 9-3 tid 150

    Trim : vector sport

    Engine : Z19DTH

    Year : 2004

    Mileage : 156000

    Default engine light problem

    02 2.0dti

    the dreaded engine light on my veccy keeps coming on, but if i take it out of gear and keep the clutch down and free wheel for a few seconds, it will go out, theres no pattern to it coming on, just when it feels like it, (busy roundabouts) are its favourite at the mo!!!

    any ideas?

  2. #2
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    11 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Needs the fault code(s) reading out. Far simpler than guessing.

  3. #3
    Regular Member
    Join Date
    Apr 2007
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : CDTI 150

    Trim : Design

    Engine : Z19DTH

    Year : 2005

    Default

    As Dave says code reader is best bet.
    Could possibly be the spring for the clutch. There is a modified one available. Basically the error is through the cruise control. May explain why it goes out if you depress the clutch.

  4. #4
    New Member neil9629's Avatar
    Join Date
    May 2009
    Location
    newcastle-upon-tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 9-3 tid 150

    Trim : vector sport

    Engine : Z19DTH

    Year : 2004

    Mileage : 156000

    Default

    ive tryed doing the manual thing with brake and stuff but engine light won't flash, ill chuck it on pals computer and update then,

    thanks..........neil

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 16th August 2012, 10:07
  2. Rear Signum Light problem problem - help
    By scw02102 in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 8th July 2012, 21:12
  3. Idle problem, loss of power, engine management light on.
    By Coyney in forum Engine & Drivetrain
    Replies: 7
    Last Post: 10th July 2011, 10:57
  4. Replies: 3
    Last Post: 28th April 2009, 19:49
  5. Engine `spanner' light + auto transmission problem
    By omega2498 in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 25th July 2007, 21:38

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •