User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Poor fm radio reception (CD70)

  1. #1
    Regular Member
    Join Date
    May 2009
    Location
    London
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Poor fm radio reception (CD70)

    Hi everyone, I live in London so theres good fm reception in my area but the cd70 Nav head unit in my 2007 Vectra Sri has a rubbish signal. I just got the car after having an 03 Nissan primera (with the clarion sat nav system) and the reception on the Primera was perfect. Even local stations seem to have interference. Im wondering if anyone else has this problem or is it just me. I bought a Halfords aftermarket aerial and theres only a very small improvement but it looks ugly.

    The car already had a parrot phone adaptor fitted so I was thinking a mistake could have been made while someone installed it.

    The signal is ok when stood still its only while driving that it starts to drop. Its not a complete dropout but a slight shshsshsshhsshshhhh every few seconds in the background.

    Anyone have ideas?

    Thanks for reading!
    Last edited by av2009; 8th June 2009 at 02:15.

  2. #2
    Regular Member bushygrunt's Avatar
    Join Date
    Sep 2008
    Location
    Wakefield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I should think the warrenty should cover this, try your local stealers.

  3. #3
    Ex-Staff Full Member Taffyopel's Avatar
    Join Date
    Oct 2007
    Location
    Horley, Surrey
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Could very well be your aerial my friend.

    I fitted one of those stubby ones and it was naff. Couldn't get Capital, Kiss, Magic, nothing, only Radio 1...............sometimes!!

    Get down to your dealers and fit the proper one and that should cure it.

    HTH

    Paul.


    Snowman, you got your ears on?

  4. #4
    Regular Member
    Join Date
    Oct 2008
    Location
    Bradford
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    My CD70 is the same. Rubbish signal on FM.

    My previous Passat's VW Gamma stereo was the same - i eventually fitted an in-line aerial booster from Halfords for £15, and it improved things greatly. Havent got round to fitting it on the CD70 yet.

    However, I usually listen to Radio2 and Radio4 - signal is ok with these stations.

  5. #5
    Regular Member
    Join Date
    May 2009
    Location
    London
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by ShamusUK View Post
    My CD70 is the same. Rubbish signal on FM.

    My previous Passat's VW Gamma stereo was the same - i eventually fitted an in-line aerial booster from Halfords for £15, and it improved things greatly. Havent got round to fitting it on the CD70 yet.

    However, I usually listen to Radio2 and Radio4 - signal is ok with these stations.
    Thanks for the replies everyone, but what booster exactly are you talking about? The only one I can see on Halfords site is the Autoleads PC5-52 Signal Filter, I dont think this is it. I would appreciate it if you could tell me the exact product name. The aerial I have is the original long one so that cant be an issue.

    Thanks again
    Last edited by av2009; 8th June 2009 at 20:30.

  6. #6
    Regular Member
    Join Date
    Oct 2008
    Location
    Bradford
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by av2009 View Post
    Thanks for the replies everyone, but what booster exactly are you talking about? The only one I can see on Halfords site is the Autoleads PC5-52 Signal Filter, I dont think this is it. I would appreciate it if you could tell me the exact product name. The aerial I have is the original long one so that cant be an issue.

    Thanks again
    Here you go ... one on ebay for £5. It lists the Vectra also. It goes behind the head unit, where the aerial plugs in. Should do the trick, although it might be worth running by your local ICE specialist (... not Halfords ...).

    http://cgi.ebay.co.uk/AUDI-VAG-VW-Se...3A1%7C294%3A50

  7. #7
    Regular Member
    Join Date
    May 2009
    Location
    London
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by ShamusUK View Post
    Here you go ... one on ebay for £5. It lists the Vectra also. It goes behind the head unit, where the aerial plugs in. Should do the trick, although it might be worth running by your local ICE specialist (... not Halfords ...).

    http://cgi.ebay.co.uk/AUDI-VAG-VW-Se...3A1%7C294%3A50
    Thanks for the link, much appreciated. One more thing where will the blue wire go?

  8. #8
    Regular Member
    Join Date
    Oct 2008
    Location
    Bradford
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by av2009 View Post
    Thanks for the link, much appreciated. One more thing where will the blue wire go?
    No worries....

    To be honest, i cant remember what the extra wire is for (possibly something to do with the mute or speed sensor for autovolume). Sorry.

  9. #9
    Regular Member
    Join Date
    May 2009
    Location
    London
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by ShamusUK View Post
    No worries....

    To be honest, i cant remember what the extra wire is for (possibly something to do with the mute or speed sensor for autovolume). Sorry.
    I found out it connects to the remote wire(12V) . In the case of the CD70 its the yellow wire (its usually blue).

  10. #10
    Regular Member Petiemc's Avatar
    Join Date
    Jan 2013
    Location
    Bourne
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Does anyone have more ideas for this problem? its doing my head in!!!!!!!!!!!!!!

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. poor radio reception with 8k HID's
    By tights in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 13th February 2011, 00:17
  2. Poor Radio Reception Please Help
    By dizzy in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 16th October 2008, 17:25
  3. poor radio reception ??
    By dizzy in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 16th October 2008, 16:34
  4. Poor Radio Reception
    By testbloke in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 28th August 2008, 23:11
  5. Very Poor Radio Reception???
    By ChrisFox in forum Electrical & ICE (including SatNav)
    Replies: 9
    Last Post: 2nd January 2008, 20:36

Visitors found this page by searching for:

poor fm reception on vauxhall tigra

why have i got poor radio reception in my vectra c

2010 vauxhall insignia radio reception poor

vectra c poor radio reception

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •