User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: CD 70 Screen problems

  1. #1
    Regular Member
    Join Date
    Mar 2007
    Location
    Gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default CD 70 Screen problems

    Last night when driving home I noticed that the colour screen on my CD 70 Navi was blank. The stereo is still working, but nothing at all on the screen. I have had a quick look at the fuses but they seem ok, but I will try new ones (No. 17 and 26 in the passenger bay). The next step is to see if a lead has become unplugged, but I was wondering if anyone can throw any light on this problem. I have had a search on the forum but cant find any relevant items.

  2. #2
    Regular Member Flaninacupboard's Avatar
    Join Date
    Oct 2006
    Location
    Wellingborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    My first guess (and hope for your sake!) would be loose cable. only takes a second to remove the headunit so that's what i'd check first.

  3. #3
    Regular Member
    Join Date
    Mar 2007
    Location
    Gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If only it had been that simple!! Took head unit and screen out and cables all ok, with power going to them. Guessing the screen has gone, but will continue to have a play around.

  4. #4
    Regular Member Flaninacupboard's Avatar
    Join Date
    Oct 2006
    Location
    Wellingborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It could be the backlight that's gone. take a very close look at the screen under a good light and see if you can see anything in it at all.

  5. #5
    Regular Member
    Join Date
    Mar 2007
    Location
    Gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    you mean literally shine a torch into it and see if anything appears on the screen? Nope absolutely blank

    must admit havent got round to changing fuses to see if they have gone but they look ok.

    even when you turn lights on there is nothing, not even a hint of light....very strange. Out of interest I phoned VX for a price for a screen.....its a bargain at £1285.00!!!!! Think I will get two and keep one as a spare!!

    Will keep trying, but if no look suspect it may be cheaper to buy a whole new CD70 Navi unit

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Half screen to full screen,
    By SlowCoach in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 14th May 2012, 01:13
  2. new screen now screen wiper problem
    By kenno31 in forum Bodywork & Interior
    Replies: 4
    Last Post: 18th February 2012, 12:34
  3. 3.2 Elite central screen problems
    By crucial in forum Electrical & ICE (including SatNav)
    Replies: 22
    Last Post: 31st December 2010, 13:02
  4. Wiper blades and screen wash pump problems
    By lee1980 in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 28th November 2010, 14:50

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •