User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 2.0DTI keeps dying

  1. #1
    Regular Member
    Join Date
    May 2009
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.0DTI keeps dying

    Can anyone help? i have an 04 Signum 2.0DTI. It has developed a very annoying problem. When I start it from cold it runs well and will continue to run until I stop the engine. If I then start the engine warm, it will do about a mile until the spanner comes on and it will not rev above tickover. Try to start it too soon, it will rev and then immediately revert to tickover and not rev at all. Leave if about five mins and it will start again and run fine until I next have to drop to tickover (junction etc.) then the spanner comes on again.

    It has had a new air mass sensor (which was the error showing when this palaver started) and I have cleaned the boost pressure sensor and the EGR valve. When I take it in, apparently there is no error code showing so the garage are as baffled as me.

    Has anyone any idea what could be going on? Any suggestions gratefully received as it is driving me spare!

  2. #2
    Regular Member duncan2008's Avatar
    Join Date
    Aug 2008
    Location
    Dewsbury
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sounds dodgy mate! how did you clean the egr? perhaps its damaged and needing replaced!

  3. #3
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    Do a manual code read to recover stored fault codes. Most generic fault code readers will only collect active faults.

  4. #4
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    56 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    I have a code reader if you pop over i can try and get codes i live in Teignmouth btw

  5. #5
    Regular Member
    Join Date
    May 2009
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks, all - I cleaned the EGR iaw the advice on this site. If by the manual method of getting codes, you mean doing the brake and accelerator thing, I have done that and the engine symbol does not blink! Bigmac, thanks for your offer - I am supposed to be going up to my youngest daughter's birthday tomorrow and if I do not make it, I will be in contact!

  6. #6
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Sounds like dodgy pump electronics to me

  7. #7
    Regular Member
    Join Date
    May 2009
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks - I will have a look.

  8. #8
    Regular Member
    Join Date
    May 2009
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I am not going to say this too loud but I think I might have fixed it! There is some sort of actuator just above the EGR valve and it was loose in its housing and the shaft was a bit stiff. Modified the housing slightly with a pair of pliers and freed the shaft with some WD40. Drove 45 mi , stopping several times. No recurrance of problem. Fingers crossed ....... . Anyway thanks for the help.

  9. #9
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    56 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    touch wood mate

  10. #10
    Regular Member
    Join Date
    May 2009
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Touch it? I have been carrying a tree around!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. the last dying wish....
    By chewy71 in forum Comedy & Humour
    Replies: 5
    Last Post: 17th July 2012, 12:48
  2. is my dmf dying
    By neill in forum Engine & Drivetrain
    Replies: 5
    Last Post: 20th December 2011, 10:00
  3. I am dying – Man Flu!
    By coldo in forum General Chat
    Replies: 3
    Last Post: 10th October 2010, 17:53
  4. I'm Dying
    By VauxVeteran in forum General Chat
    Replies: 6
    Last Post: 20th December 2007, 01:58
  5. F1 Is Dying
    By VauxVeteran in forum General Chat
    Replies: 22
    Last Post: 7th August 2007, 13:41

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •