User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: 1.9 cdti 150 problem

  1. #1
    Regular Member
    Join Date
    May 2009
    Location
    beds
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    confused 1.9 cdti 150 problem

    guys help me
    i have a 2005 vectra its a 1.9 cdti 150, it was going into lim mode so i found out the manifold had a fault, i changed that and now it doesnt go into lim mode instead it slows down.it doesnt have much power it feels like it cutting off because i can feel the car being pulled back,this was happening before when it was going into lim mode, but this time the warning light dosent come on,so it cant be going into lim mode. it is ok when driving local but when i hit the motorway thats when it slows down, if i switch it off and start it again then its fine but then 3 mins later it happens again

    any advise

  2. #2
    Regular Member
    Join Date
    Jul 2008
    Location
    Winteringham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    EGR Fault???

  3. #3
    Regular Member
    Join Date
    May 2009
    Location
    beds
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default thanks for the reply

    Quote Originally Posted by gregc View Post
    EGR Fault???
    can you tell me more please, it just slows down when i restart then its fine,please reply

  4. #4
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    that will be the EGR valve m8, its bolted on to the manifold, might need a good clean out, if not it will need replacing

  5. #5
    Regular Member badback's Avatar
    Join Date
    Jan 2009
    Location
    Runcorn
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

  6. #6
    Regular Member big rich's Avatar
    Join Date
    Nov 2008
    Location
    birmingham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    welcome

  7. #7
    Regular Member Thunder's Avatar
    Join Date
    Apr 2008
    Location
    North Yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi &

  8. #8
    Regular Member mradz's Avatar
    Join Date
    Jan 2009
    Location
    Northants
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi and welcome to the site

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cdti 120 problem
    By Vidar in forum Engine & Drivetrain
    Replies: 2
    Last Post: 26th December 2012, 00:25
  2. Problem With My CDTi
    By Si-SRI in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 26th April 2011, 09:30
  3. 1.9 CDTI problem
    By chrish in forum Engine & Drivetrain
    Replies: 5
    Last Post: 26th September 2008, 10:17
  4. 1.9 CDTI 150 BHP problem
    By sumpyboy in forum Engine & Drivetrain
    Replies: 2
    Last Post: 18th July 2007, 21:31
  5. CDTi MPG? do i have a problem?
    By Andy in forum Engine & Drivetrain
    Replies: 22
    Last Post: 9th November 2005, 17:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •