User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: swirl and boost sensor 1.9cdti 150

  1. #1
    Regular Member
    Join Date
    Apr 2009
    Location
    uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default swirl and boost sensor 1.9cdti 150

    Can anyone tell me where the swirl flaps and boost sensor is on the 1.9cdti 150.
    Pictures would be better.
    Just stripped the EGR, and good G*d almighty what a mess, 1/4 inch of soot in there.
    So just want to check all the rest.

  2. #2
    Regular Member
    Join Date
    Apr 2009
    Location
    uk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    done the sensor as well.
    could do with knowing about the swirl valves as well though
    seeing as though they were just lying in engiene bay
    do they pop into place in th holes and stay there

  3. #3
    Regular Member keithsimmo's Avatar
    Join Date
    Dec 2007
    Location
    in the engine compartment.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats






Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cleaning Boost Sensor, 1.9CDTi ????
    By mpc in forum Vectra C / Signum Car Chat
    Replies: 11
    Last Post: 8th July 2010, 23:11
  2. CDTI 150, 10k Boost De-Coked & New Boost Sensor
    By Vaux-Man-G in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 4th January 2010, 12:02
  3. 4th Swirl: Covered in Oil 1.9CDTI 150
    By barkzz in forum Engine & Drivetrain
    Replies: 6
    Last Post: 22nd December 2009, 16:04
  4. cleaned boost sensor and still shows over boost
    By chowwie in forum Engine & Drivetrain
    Replies: 2
    Last Post: 14th November 2008, 09:23

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •