User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: why does it go slow

  1. #1
    New Member
    Join Date
    May 2009
    Location
    colchester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default why does it go slow

    Hiya everyone.

    My name is Lyndz and im kind of hopeing you guys might be able to help me as im having trouble with my car. im not used to forums so you will have to bear with me. lol.

    The problem with my car is for the past couple of months there has been no power at all it is like the turbo has been switched off, now when i get on the motorway i get up to about 75 ish and the car just dips in power and a spanner light comes on. now the car did this once before whenthe turbo was working and it went off when i stopped all was ok again then i got it serviced about 2 wks l8tr and since the service there has been no power. Now i know nothing about cars but if you guys might be able to tell me what it might be andrough idea how much it will cost to fix that wouldbe appreciated. The reason I am worried is ive got 2 young girls and i am worried its going to cost a fortune.

    sorry for my life story.

    Hope someone can help?

    Lyndz x x x

  2. #2
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    sounds like the EGR vaulve is playing up

    best bet is to get it code read at the dealers, unless you know someone with a tech 2 machine

  3. #3
    Regular Member KSD's Avatar
    Join Date
    Aug 2007
    Location
    Cupar, Fife
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like your turbo may be seized, it happened to a mates mondeo, the impeller atachment nut came off and jammed the turbo, not cheap to fix cos it was a new turbo that was needed. If the car is under warranty, that should cover it, if not I hope it is something a little more trivial.

  4. #4
    Regular Member mark1976's Avatar
    Join Date
    May 2009
    Location
    Barrow on Humber
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I agree with glynn, sounds like EGR valve or possibly air flow sensor?

  5. #5
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Given your engine (2.0DTi) it could be the (very) common problem of split boost hoses, so common that Vx brought out a modified part (reinforced boost hose). Go over all the boost hoses very carefully, including underneath, feeling for any splits. They may feel very small but when the boost is going through they soon open up and that will cause the limp mode (spanner).

    I take it when it does it on the motorway, it's probably when you're in say 5th gear and lower revs just as you are starting to accelerate? If so then that's classic symptoms of that. There's also another hose that can cause issues i.e. also split but my brain's seized and I've forgotten which one. Think it is a vacuum pipe.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Slow to pull away - dangerously slow to pull away (150cdti auto)
    By the1theycallthe1 in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 29th March 2012, 21:10
  2. Is LMF always this slow?
    By Celes in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 24th December 2010, 11:22
  3. very slow warming up
    By IA76 in forum Engine & Drivetrain
    Replies: 27
    Last Post: 28th April 2010, 19:27
  4. Slow 2.2
    By SUPERBIRDSXI in forum Petrol Engine related
    Replies: 38
    Last Post: 23rd March 2007, 14:50
  5. Slow down !!!!
    By richardg3.2 in forum General Chat
    Replies: 5
    Last Post: 13th May 2006, 19:18

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •