User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: HELP....battery light on dash?

  1. #1
    Regular Member
    Join Date
    Aug 2007
    Location
    somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default HELP....battery light on dash?

    hi chaps
    today i have had the battery icon light illuminated on my dash......by the time i got home power steering stopped working with another warning icon of a steering wheel with a ''!'' it was then very hard to manouvre on to my driveway....i have faith in this forum that someone would be able to point me in the right direction of what my problem is... i have a signum 1.9 cdti '05 elite....
    thanks in advance

  2. #2
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The auxiliary belt has probably snapped, pop the bonnet and have a look to see if theres a belt running around the alternator etc HTH.

  3. #3
    Regular Member
    Join Date
    Aug 2007
    Location
    somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    that was a quick reply....i will have a look at that in the morning....getting a little dark right now...hope it is that as it sounds a cheap,quick,easy fix...any more suggestions?

  4. #4
    Regular Member phil67's Avatar
    Join Date
    Aug 2005
    Location
    Nottinghamshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : Exclusive

    Engine : 1.8

    Year : 2005

    Default

    If not the drive belt ,it may be the alternator. Mine was the alternator...

  5. #5
    Regular Member cameraman's Avatar
    Join Date
    Sep 2006
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I was driving down the M1 when all the warning lights started coming on, mine was the alternator ( 2 MATES AT WORK HAD THE SAME PROBLEMS TOO) all 1.9cdti 150's around 06-56 plate

  6. #6
    Regular Member byebyeitsagsi's Avatar
    Join Date
    Jun 2008
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Auxiliary belt = Much cheapness, alternator = ouch.

  7. #7
    Regular Member
    Join Date
    Nov 2008
    Location
    ipswich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i got an 05 1.9 cdti, and my alternator gone, started with the battery warning light than it was high idling, i spent a while driving round getting it diagnosed, then power steering went and finally all instruments and lights ceased to work, £150 for a new alternator from HMF in huntingdon and £50 to get it fitted by a mate. definately something you want to get sorted asap, all this happened today lol, not a happy person!

  8. #8
    Regular Member
    Join Date
    Mar 2006
    Location
    Belfast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Power steering on the Vectra is electrically driven, and a very high current draw, so it's shut down by the BCM if the alternator isn't producing enough juice. Chances are it's the alternator, as they're pretty crap quality.

  9. #9
    Regular Member frasedeb's Avatar
    Join Date
    Mar 2009
    Location
    hull
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    had exactly the same about 3 weeks ago for about half hour, then all went back to normal and fine since.
    i put it down to maybe a slipping aux belt.( i hope).

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 18th August 2012, 08:58
  2. Replies: 17
    Last Post: 16th August 2012, 10:07
  3. Battery Light ON - 14.1 volts at battery
    By snapsnap in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 6th December 2011, 13:55
  4. Alternator/Battery Dash Warning Light
    By cavester in forum Vectra C / Signum Troubleshooting
    Replies: 31
    Last Post: 1st June 2011, 08:24
  5. battery light and a demented dash, any suggestions?
    By TKD Colin in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 19th January 2009, 21:40

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •