User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Online Order RANT!!!

  1. #1
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Online Order RANT!!!

    First of all a message to ADMIN: if using the name of this retailer is inappropriate, please change the retailer name to Online Retailer. Thanks. Please dont remove this thread as I am seeking genuine help. Thank you!

    HELP!!

    I placed an order with PLAY.COM on the 5th of May for a TomTom, they claim to have desptached it on the 6th, and today we are on the 15th and I still have nothing!

    I have contacted them and they have said that there is nothing they can do as its sent via Royal Mail and they have stipulate which service was used (probably a non-existent one)!

    Anyway, I have been in touch with them again after the initial 5 WORKING DAYS and they are now telling me that they cannot trace, track or resolve claims until after 21 calendar days.......... !

    Im getting soo pee'd off. I called them before I placed the order and they said it would be with me within 3-5 working days and all their parcels are tracked. The lady said in this case, we used Royal Mail-normally we would use a courier service, but she couldnt advise as to why it was different this time round.

    Anyway, so after 3 days of ranting and raving at them over the phone, I have finally got a Missing Item Confirmation Form from them which I am about to return to them but even with this, regardless of what service I use, will not be actioned until 5 days! GREAT! AND I CAN ONLY SEND THIS FORM VIA POST!!! !

    What should I do, cancel the transaction and order from elsewhere, or should I sit tight and wait!

    Would never use them again! I have sent things to the other side of the world quicker than this!

    Anyone else had a similar issue?
    Last edited by Stevel; 15th May 2009 at 13:15.


    Bye bye Vec B
    - Hello Siggy!

  2. #2
    Regular Member Sean-2.2Direct's Avatar
    Join Date
    Apr 2008
    Location
    Liverpool
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    unlucky mate I have never used play.com before

  3. #3
    Regular Member lofty's Avatar
    Join Date
    Sep 2007
    Location
    @home
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate

    Trim : Elite

    Engine : 1.9 CDTi


    Default

    Royal mail won't class a parcel as missing for 15 days of postage so that is not a play issue. Had a similar issue with a company claiming not to have rec'd a return parcel.. could not do anything until the 15 days had passed, then had to send a claim form off to RM. Turns out the company had signed for the return the next day after all!!

    Be patient..

    I've ordered a lot of stuff from play myself and not had any issues.

  4. #4
    Regular Member
    Join Date
    Mar 2009
    Location
    Somerset
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    happened to me a few years ago, then 2 months down the line my cousins birthday pressie arrived at my door. Play had already refunded me though lol

  5. #5
    Regular Member adfrodsham's Avatar
    Join Date
    Jul 2008
    Location
    lincoln
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    never a drama with play.com myself

  6. #6
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    same here - always use play and they have never let me down - just an unfortunate incident - it does happen - just a shame its been to you

    0-Large smile ......every time it's driven

  7. #7
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Bad experience for me then I guess, first time I used them too, and that was on recommendation! ! !


    Bye bye Vec B
    - Hello Siggy!

  8. #8
    Regular Member lofty's Avatar
    Join Date
    Sep 2007
    Location
    @home
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate

    Trim : Elite

    Engine : 1.9 CDTi


    Default

    sounds like RM are the ones at fault.. don't let it put you off..

  9. #9
    Ex Vec-C Admin Stevel's Avatar
    Join Date
    Nov 2006
    Location
    Chester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've never had a problem with them either.

    BTW The post is fine (although I've edited two words) because you are simply describing an experience. It's only when unproven accusations are made (that could lead to legal action against this site being taken) that we have a problem with.

  10. #10
    Regular Member Robbie69's Avatar
    Join Date
    Mar 2008
    Location
    Oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've used them a couple of times, never a problem. I would guess the problem is as usual with our great Royal Mail. Play should not use them and they simply aren't fit for purpose any more IMO! Hope you get it resolved soon.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What order to do it in.
    By Ginge7289 in forum Detailing and Car Care Discussion
    Replies: 10
    Last Post: 11th February 2011, 12:56
  2. WII online.... can you play online
    By m3ath3ad in forum Games Room
    Replies: 14
    Last Post: 26th April 2009, 22:12
  3. Rant, but happy rant!
    By Ean in forum General Chat
    Replies: 11
    Last Post: 19th April 2009, 17:03
  4. About to order car...
    By Draggon in forum Vectra C / Signum Car Chat
    Replies: 38
    Last Post: 23rd May 2008, 17:24
  5. Ranty rant rant!!!!!!
    By Mrs D in forum General Chat
    Replies: 16
    Last Post: 24th April 2008, 09:09

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •