User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Heater Fans Died

  1. #1
    Regular Member
    Join Date
    Feb 2008
    Location
    Newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Heater Fans Died

    Just driving on my way home with the heating on and all of a sudden they fans just stopped and wont work at all.

    Ive got 04 plate elegance estate.

    Anyone got any suggestions?

    Thanks in advance.

  2. #2
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    check the fuse? Also remove the pollen filter to check the fan isn't stuck or siezed
    Now I need a turbo to keep up!

  3. #3
    Regular Member andymcniven's Avatar
    Join Date
    Jan 2007
    Location
    newcastle upon tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    try this link i fixed mine using it
    http://www.vectra-c.com/forum/showth...hlight=heaters

  4. #4
    Regular Member Lump's Avatar
    Join Date
    Sep 2008
    Location
    coventry
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    whos Heater Fans

  5. #5
    Regular Member
    Join Date
    Feb 2009
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Lump View Post
    whos Heater Fans
    lol but

    and yes, try the fuses.

  6. #6
    Regular Member
    Join Date
    Feb 2008
    Location
    Newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    thanks for the info guys ive now checked over the fuses all look fine, as long as there is only supposed to be 3 as thats all i found related to heaters. Andymcniven i looked at your thread and checked out the blue relay looks fine the relay closes 1-3 then opens back up on number 4.
    fan isnt stuck and pollen filter side is clear.

    Any more suggestions of what it could be guys?

  7. #7
    Regular Member
    Join Date
    Feb 2009
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    loose connections on back of heater controls?

  8. #8
    Regular Member
    Join Date
    Feb 2008
    Location
    Newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    would that be relevant if the lights still show for the windscreen demisting button and that doesn't turn the fans on either.

    Sorry if im sounding a bit thick aint the best with fixing cars

  9. #9
    Regular Member
    Join Date
    Feb 2009
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    not too sure mate, however i did have my heater controls puller out earlier when i was messing with my phone kit and there were definatly 2 conectors.

  10. #10
    Regular Member
    Join Date
    Feb 2008
    Location
    Newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    think i may have solved the problem, upon closer inspection there has been water coming in through the fan and resistor pack is wet so i think after reading some of the write ups on here i might change that first

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. heater fans not blowing
    By Jaspa in forum Electrical & ICE (including SatNav)
    Replies: 7
    Last Post: 3rd December 2011, 16:37
  2. heater fans not working?
    By Jaspa in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 2nd December 2011, 23:06
  3. Which relay controls heater fans
    By Darrell in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 11th November 2009, 19:00
  4. Car Died!!
    By Silver V in forum Vectra C / Signum Car Chat
    Replies: 32
    Last Post: 2nd July 2007, 10:31

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •