User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Mass Air Flow Sensor

  1. #1
    Regular Member
    Join Date
    May 2008
    Location
    Llanelli
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Mass Air Flow Sensor

    Whilst driving my Car went into reduced power and displayed the 'spanner' symbol to indicate a fault. I restarted the engine and it drove normally for about half a mile and then reappeared. After the restart the engine diagnostic light came on and remained on so I booked it into the garage.

    The Dignostic printout at the garage read

    "Fault Codes

    DTC: P0100
    Mass Air Flow Sensor
    Voltage Supply Circuit.
    Present."

    The garage told me that they had checked the part and that it was okay and that it drove okay when they tested it and they gave the car back to me. I assume that they just took it down the road.

    I have just driven to work and on fast acceleration on motorway the fault has reappeared.

    Does anybody have experience of this problem and know what the possible solution is?

  2. #2
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    answered on other post for this.

  3. #3
    Regular Member poves's Avatar
    Join Date
    Dec 2007
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had this happen in my old dti sri , just take the plug off the maf and spray with wd40 , it sorted mine so it's worth a try.

  4. #4
    Regular Member
    Join Date
    May 2008
    Location
    Llanelli
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Car went back into garage today and they told me that the problem on the car is in effect a Turbo overboost but they dont know what is causing it. He mentioned that there were 2 ways to get to the bottom of the issue,

    1) using a Cambus system??? which they dont have which can test solenoids/sensors on computer system - only available from main dealers (expensive)

    2) stripping engine down further to check for mechanical faults from faulty 'air valves'

    Any experience or ideas on what I should do next?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. For Sale: Vectra Mass Air Flow Sensor
    By CraigoT in forum Parts for sale
    Replies: 4
    Last Post: 25th September 2012, 22:59
  2. Mass Air Flow Meter
    By shug176 in forum Troubleshooting
    Replies: 8
    Last Post: 31st March 2012, 18:51
  3. mass air flow sensor
    By vectra craig in forum Engine & Drivetrain
    Replies: 4
    Last Post: 3rd September 2009, 19:53
  4. Mass Air flow Sensor fault
    By stroake in forum Troubleshooting
    Replies: 3
    Last Post: 12th May 2009, 12:34
  5. maf sensor mass air flow for sale
    By mattolly86 in forum Parts for sale
    Replies: 3
    Last Post: 19th March 2009, 19:42

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •