User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: 2.2 Petrol Misfire/Stalling Help Needed

  1. #1
    Regular Member
    Join Date
    May 2009
    Location
    cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused 2.2 Petrol Misfire/Stalling Help Needed

    Hi

    I have a 2.2 petrol vectra c and each time you start it up it'll stall, it tries to fight this but in the end it stalls, my mate reckons it is misfiring. Once started and going it runs fine this just happens on startup. I put on a diagnostic tester and there are no fault codes being stalled, i've changed spark plugs and cleaned EGR valve but the problem is still persisting!!! Can anybody help me please?

    John

  2. #2
    Regular Member davree's Avatar
    Join Date
    Jan 2009
    Location
    Warton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRi

    Engine : 2.0 CDTI (160)

    Year : 2010

    Mileage : 26000

    Default

    You could try changing the fuel filter for a start (they are quite cheap). Also try cleaning the throttle body!!

    You could have a faulty/clogged injector, you could try putting some redex or similar in the fuel which contains injector cleaner to try and clean them up.

    HTH

  3. #3
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Coil pack or o2 sensor. Mine misfires a little on start up, but as soon as its under load it goes. Mine's due to a sticky hydraulic lifter. Does it make any noises at all?

  4. #4
    Regular Member
    Join Date
    May 2009
    Location
    cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ok will try fuel filter,have had a little go at cleaning the throttle body but i'll take it off to clean it next, will also purchase some redex, it makes abit of a knocking noise when its trying to start but that about it, can i just enquire where is the o2 sensor? not sure what one is or does?

  5. #5
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    O2 sensor is the lambda sensor mate, one in front of the Cat and one after.

  6. #6
    Regular Member
    Join Date
    May 2009
    Location
    cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Thumbs down worse

    Hi have used some redex and have changed fuel filter, problem seems to have got worse, its constantly searching for revs when its started up also i now have a MIL light coming on. Will clean the throttle body and EGR Valve once more has anyone got anymore ideas?

  7. #7
    Regular Member simon1's Avatar
    Join Date
    Oct 2007
    Location
    Leicester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    3 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra elite

    Trim : Elite

    Engine : 1800

    Year : 2004

    Mileage : 80000

    Default

    i would change the coil pack mates vectra b 2.2 had similar problems

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Low rev misfire. 2.2 petrol
    By jrh1 in forum Vectra C / Signum Troubleshooting
    Replies: 10
    Last Post: 19th September 2012, 16:38
  2. 1.8 petrol stalling
    By baz_cdti_sri_150 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 16th February 2011, 21:01
  3. cdti 150 slight misfire! help needed
    By craigz9876 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 30th October 2009, 11:11
  4. 3.2 V6 Petrol GSi Misfire Under Load
    By marcdale in forum Engine & Drivetrain
    Replies: 9
    Last Post: 31st May 2009, 21:22
  5. signum 2.2 petrol misfire
    By scotty6w in forum Engine & Drivetrain
    Replies: 15
    Last Post: 14th July 2007, 14:03

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •