User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Turbo Advise Please!

  1. #1
    Regular Member sberrow's Avatar
    Join Date
    Jul 2008
    Location
    Newport (Gwent)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Turbo Advise Please!

    I have been having problems with my boost presure, when in high gears ie 4 5 6th, when hard excelerating i loose boost presure completly! you can sort it by stopping the car turning off egnition and re starting, lately has been happening a lot more. looking through the posts on here i found Duncan had a simular problem, I have now decided to have the turbo serviced. I am running a full bsr stage 3, and was playing with the idea of the having the turbo made into a hybrid turbo. Advice Please!!

  2. #2
    Regular Member Super T's Avatar
    Join Date
    May 2007
    Location
    On the Levels
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you tried changing the boost sensor yet??I've heard the switch/motor slows after time. As the sensor is only £60 and the service is £250/£350 it's worth a try!!By the way mine has been fine since we met at Magor.

  3. #3
    Regular Member sberrow's Avatar
    Join Date
    Jul 2008
    Location
    Newport (Gwent)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    had a new sensor last summer.

  4. #4
    Regular Member Super T's Avatar
    Join Date
    May 2007
    Location
    On the Levels
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Come on tech's give the man a hand.

  5. #5
    Regular Member Super T's Avatar
    Join Date
    May 2007
    Location
    On the Levels
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you tried fitting your spare actuator??

  6. #6
    Full Member gibbon7000's Avatar
    Join Date
    Dec 2008
    Location
    lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Could it be the barometer sensor???, Just had to have mine changed.

    My other car. 1972 1641cc slammed beetle. On the road finally!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 19
    Last Post: 6th September 2014, 13:54
  2. HELP PLEASE looking to buy this but need advise first
    By mattbrad30 in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 6th June 2012, 20:23
  3. Can Anyone Advise...............
    By spennny in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 16th May 2012, 16:25
  4. Need Advise Please
    By spennny in forum General Chat
    Replies: 25
    Last Post: 9th May 2009, 21:05
  5. Please Advise
    By Amo the Dark Prince in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 12th April 2008, 08:17

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •