User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: What's wrong with my Vectra??

  1. #1
    Regular Member zazaszazas's Avatar
    Join Date
    Jan 2009
    Location
    Cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default What's wrong with my Vectra??

    Have a problem with my Vectra.Ok here is my story..Bought the car 3months ago and while i was driving it over bumps i've had a knocking noise from the back and the front of the car.Also when i'm driving it over bumps there is a sort of shaking coming from the back of the car.Recently changed springs(Konis all around),front anti roll bar links and the rear control arms.There is still knocking noise and the shaking What to do next?? Btw I've got Gt Champiro tyres fitted(cost £80 each)

  2. #2
    Regular Member n_hudson's Avatar
    Join Date
    Mar 2008
    Location
    Northampton, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you checked the simple things like the radiator mounts?

    When I took my front bumper off for the first time, I noticed that the steering fluid bottle was loosely held on as the mounting cage had been damaged at somepoint, so that was bumping around over bumps ( I was lucky to notice that!).

    Then I had trouble with the rubber airbox mounts, that was bouncing around everywhere.

    Then I noticed that the front bumper didnt have any plastic push rivets holding it to the underneath of the car, so that was slapping around...

    With the back, I'd check your exhaust mounts as a starter for the knocking noise...

  3. #3
    Regular Member zazaszazas's Avatar
    Join Date
    Jan 2009
    Location
    Cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by n_hudson View Post
    Have you checked the simple things like the radiator mounts?

    When I took my front bumper off for the first time, I noticed that the steering fluid bottle was loosely held on as the mounting cage had been damaged at somepoint, so that was bumping around over bumps ( I was lucky to notice that!).

    Then I had trouble with the rubber airbox mounts, that was bouncing around everywhere.

    Then I noticed that the front bumper didnt have any plastic push rivets holding it to the underneath of the car, so that was slapping around...

    With the back, I'd check your exhaust mounts as a starter for the knocking noise...
    Thanks for the advice.I'll have a look over the weekend..the front sounds like some sort of metal knocking..I was thinking the steering rack or driveshaft or might be the shock absorbers?? but still why is the rear end shaking when i drive thru bumps??Sure its something to do with the suspension isn't?

  4. #4
    Regular Member mishima's Avatar
    Join Date
    Sep 2008
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have exactly the same problem. I have replaced upper control arms and ARB bushes. Still there. It's very annoying, if you discover what is wrong wit yours please post up!

  5. #5
    Regular Member zazaszazas's Avatar
    Join Date
    Jan 2009
    Location
    Cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by mishima View Post
    I have exactly the same problem. I have replaced upper control arms and ARB bushes. Still there. It's very annoying, if you discover what is wrong wit yours please post up!
    will do m8..well i'm going to change my shock absorbers for Koni ones and i'll see if that will make any difference

  6. #6
    Regular Member glenboy's Avatar
    Join Date
    Jul 2007
    Location
    Sunny Dartmoor
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you changed your drop links?

    They're about £20 for the pair and can give you a knocking noise,worth a try m8.........

  7. #7
    Regular Member Stevie-B's Avatar
    Join Date
    Mar 2007
    Location
    NI
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Glenboy is spot on here... it cured my problem after the knocking was still there after getting the rear control arms replaced.

  8. #8
    Regular Member zazaszazas's Avatar
    Join Date
    Jan 2009
    Location
    Cumbria
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by glenboy View Post
    Have you changed your drop links?

    They're about £20 for the pair and can give you a knocking noise,worth a try m8.........
    as i said i've changed the drop links(anti roll bar links)and the knocking noise still there

  9. #9
    Regular Member mishima's Avatar
    Join Date
    Sep 2008
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Same for me, replaced all those parts and still that nasty noise. Watching this thread closely!

  10. #10
    South Wales Assistant Regional Organiser davidjameswest's Avatar
    Join Date
    Feb 2009
    Location
    llantwit major
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    go for a drive and let some one else drive while your in the back and fold the back seats down and see if you can hear it to give you a better clue

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Brought used vectra Sri 1.9cdti 2006 what could be wrong???
    By King of Lead in forum Engine & Drivetrain
    Replies: 16
    Last Post: 2nd June 2012, 22:43
  2. Vectra C 1.9CDTi SRi - wrong wheels?
    By Tigerrider in forum Suspension, Wheels & Brakes
    Replies: 27
    Last Post: 24th September 2010, 18:40
  3. The Vectra has all gone wrong in the sun
    By tramman in forum Vectra C / Signum Troubleshooting
    Replies: 10
    Last Post: 24th May 2010, 22:35
  4. What else can go wrong with my Vectra?
    By BRYBURN in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 13th January 2010, 21:43

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •