User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: lights on dash and other probs

  1. #1
    Regular Member
    Join Date
    Jul 2007
    Location
    TENBY/BELFAST
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default lights on dash and other probs

    Hi guys been a while since iv been on here,was driving about an hour ago and the light that looks like a spanner with a car behind it came on,car shuddered then battery light came on ,so i turned it off and started the car again and it went away and i continued driving then it came on again then the battery light.......then temperature light came on and temperature was in the red,pulled over ant opened bonnet and coolant is now leaking but its not low on level.each time i drive for 5 mins the spanner light comes on the the battery light and temperature goes mad.
    all help welcome......2004 signum 2.2dti elegance

  2. #2
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Leaking water from where? It could be the cylinder head gasket leaking or the water pump.

  3. #3
    Regular Member
    Join Date
    Jul 2007
    Location
    TENBY/BELFAST
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No the leak appears to be coming from the bottom of the coolant resovoir,were can i find the drive belt in the engine to check it any one got a pic of were to look.

  4. #4
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    2.2dti doesn't have a cam belt its a chain so I will assume the aux belt drives the water pump?
    Now I need a turbo to keep up!

  5. #5
    Regular Member
    Join Date
    Jul 2007
    Location
    TENBY/BELFAST
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well i went and had a look myself and its the belt but it doesnt seem to have snapped,so whats the damage im looking at and what sort of costs.Is it still safe to drive to the garage.

    Last edited by miximup; 7th May 2009 at 19:08.

  6. #6
    Regular Member
    Join Date
    May 2006
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This sounds as if this belt is supposed to be driving the water pump (when on correctly)so it will overheat if not driving the water pump. If you are more than 5 minutes drive from the garage, it will start to overheat again on the way there. Overheating is not good for longevity of the engine. If you are a member of the AA or RAC call them out if you have that cover. Other thing you can do is take out the thermostat and the cars water would take longer to boil up thus enabling you a greater distance to drive and have it fixed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Dash lights
    By stuk2000 in forum Vectra C / Signum Car Chat
    Replies: 20
    Last Post: 27th January 2013, 21:51
  2. led dash lights and side light running lights
    By fjaimo10 in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 9th February 2012, 21:21
  3. No Dash Lights
    By Adam B in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 1st May 2010, 07:26
  4. Audi style led lights probs
    By the_wave_rider in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 16th January 2010, 12:21
  5. Dash lights?
    By Messenger in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 29th January 2009, 21:29

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •