User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: 2.0 DTi - Rev counter & Warning Lights

  1. #1
    Regular Member
    Join Date
    May 2009
    Location
    Over the hill and far away...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.0 DTi - Rev counter & Warning Lights

    Hi

    I have a little problem that no-one can seem to work out as of yet.

    I have a 2001 dti with 99,000 miles on it. It has been perfect in every way since I got it at 17k (the car only needing some brake work at 50k). I now have a problem that seems to happen mostly on warm days / short journeys once the engine gets up to temperature. The rev counter will fall to 0, and the engine spanner light & water cooling fan light (?) come on simoultaneously. The car doesn't overheat when it does this (still running at usual temps) but the engine sounds harsher than usual & hunts very badly between 0-1000rpm at idle.

    Any ideas?

    I've had the boost sensor & crank sensor mentioned as the cause, but noone has enountered similar.

    When it is running without this happening it is spot on.

  2. #2
    Regular Member
    Join Date
    May 2009
    Location
    Over the hill and far away...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just unplugged the boost sensor, and it replicated the problem perfectly. Given it a clean & reattached.

  3. #3
    Admin & Membership Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    77 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Did it fix your problem ?

  4. #4
    Regular Member
    Join Date
    May 2009
    Location
    Over the hill and far away...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by bigmac View Post
    Did it fix your problem ?
    So far, yes. But I haven't been out in the car today. Will have to wait and see if it happens again when the car is warm.

  5. #5
    Admin & Membership Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    77 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : insignia

    Trim : irmscher

    Engine : 2.0 cdti

    Year : 2009

    Default

    Keep us informed i have the same engine

  6. #6
    Regular Member
    Join Date
    May 2009
    Location
    Over the hill and far away...
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Okay, will do. Had a lot of trouble finding any information out about the 2.0dti really.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rev Counter Lights Flashing
    By cosmic in forum Insignia car chat
    Replies: 0
    Last Post: 18th December 2012, 16:00
  2. ABS and ESP warning lights
    By ChristopheCDTI in forum Suspension, Wheels & Brakes
    Replies: 0
    Last Post: 4th October 2011, 17:13
  3. warning lights on
    By luckyjohn99 in forum Suspension, Wheels & Brakes
    Replies: 8
    Last Post: 3rd August 2009, 20:33
  4. warning lights
    By lee_car in forum Vectra C / Signum Troubleshooting
    Replies: 3
    Last Post: 30th October 2008, 14:01
  5. Warning Light Under Rev Counter???????
    By sligo_eire in forum Vectra C / Signum Troubleshooting
    Replies: 8
    Last Post: 21st September 2008, 19:54

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •