User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: injectors and glowplugs

  1. #1
    Regular Member
    Join Date
    Mar 2009
    Location
    grantham, lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default injectors and glowplugs

    hi, i have a 52 plte 2.0l dti, has the comman air in fuel problem. after taking it to the local garage and them recommending i go to a diesel specialist and saying it could take from 1 hour to 5 hours to find the problem i thought i would solve the problem myself with the help of you guys.
    ive changed the leak off pipes and t peices, replaced fuel filter. taken out and clean egr valve. i done this using the info on this site, so thanks guys for that but i still have the same problem. so now im going to look at the injectors and glow plugs.
    firstly i dont think its the glow plugs cause it happens regardless of temperature, but would still like to know how to test them?
    and finally i would like to know how to access the injectors?
    this is my first diesel car and to be honest i cant wait to get another petrol, but need to cure this problem before i can sell.

  2. #2
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    is it hard to start most the time ......? regardless off temp ?.......and gives out whiteish grey smoke ? ... common problem on the vec c / signum ,. it needs the engine ecu program updateing tp the latest spec . take it to a dealer and ask them to "sps" (reprogram the ecu) the car ..this will fix your problem hope this helps benny

  3. #3
    Regular Member PAULMAC77's Avatar
    Join Date
    Jun 2008
    Location
    warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    a friend of a friend has a taxi 2.0dti and has similar problems and is still yet to sort it out after replacing fuel filter and head, leak off pipes, injector seals (supposed to be a crap job as they are half way down the injector) glow plugs all hasnt replaced yet really is the pump and the injectors, each time he has something done the problem changes ie it wouldnt start 1st thing of a mornin well but had summat done and it does now just wont start well if left for over an hour he's had it in a diesel specialists and my mate is a mechanic and he's baffled too.. if he finds anything out i will let u know sorry its not much help but your not alone

  4. #4
    Regular Member PAULMAC77's Avatar
    Join Date
    Jun 2008
    Location
    warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by benny View Post
    is it hard to start most the time ......? regardless off temp ?.......and gives out whiteish grey smoke ? ... common problem on the vec c / signum ,. it needs the engine ecu program updateing tp the latest spec . take it to a dealer and ask them to "sps" (reprogram the ecu) the car ..this will fix your problem hope this helps benny

    thats interesting as a mate has similar problem and when tryin to crank it it is puffing out white smoke.. cheers for that

  5. #5
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by PAULMAC77 View Post
    thats interesting as a mate has similar problem and when tryin to crank it it is puffing out white smoke.. cheers for that
    yeah i know about this one the hard way had a couple blow my balls on it ............. the ecu date gets a glitch and throws the pump fueling out and the glow plugs dont work to well .... there is a tsb on tis if some one knows how to look for it ........

  6. #6
    Regular Member
    Join Date
    Mar 2009
    Location
    grantham, lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    its not affected by temperature. my driveway is on a slight decline so i started reversing in so the nose was down. this helped but it still judders a bit a kicks white smoke out. if i dont use my car for a day, the day after it wont start for ages.

  7. #7
    Regular Member
    Join Date
    Mar 2009
    Location
    grantham, lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    forgot to say that once its started it runs totally fine all day.

  8. #8
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by drakeuk View Post
    its not affected by temperature. my driveway is on a slight decline so i started reversing in so the nose was down. this helped but it still judders a bit a kicks white smoke out. if i dont use my car for a day, the day after it wont start for ages.
    this could be the injector seals have you tested them ?

  9. #9
    Regular Member
    Join Date
    Mar 2009
    Location
    grantham, lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by benny View Post
    this could be the injector seals have you tested them ?
    no, thats what i was asking, been having a look round the engine to familiarise myself, as im not a mechanic but are capable of taking on most jobs, thing is i cant seem to find the injectors, everything on this engine seems so well hidden, took me months to find the power steering pump, who decided to put it there. what a clown!

  10. #10
    Regular Member PAULMAC77's Avatar
    Join Date
    Jun 2008
    Location
    warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    whats a tsb mate?

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Where are the Glowplugs on 1.9 120
    By Marky in forum Engine & Drivetrain
    Replies: 18
    Last Post: 4th January 2011, 16:21
  2. Removing stuck glowplugs/injectors etc
    By Marky in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 14th December 2010, 16:09
  3. Dti Glowplugs
    By Dazzy2006 in forum Engine & Drivetrain
    Replies: 15
    Last Post: 2nd December 2010, 20:20
  4. Maybe more then Glowplugs
    By danny1992 in forum Engine & Drivetrain
    Replies: 18
    Last Post: 24th November 2010, 15:37
  5. glowplugs
    By chris1804 in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 23rd December 2009, 10:36

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •