User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Wierd prob with fan blower speed control

  1. #1
    Regular Member
    Join Date
    Apr 2009
    Location
    Redcar
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Wierd prob with fan blower speed control

    Its a Signum Elite with climate and i have a wierd prob with it

    Sometimes when i change the fan speed manually it dosent go up or down in sequence .

    For ex if i turn it slowly clockwise it sometimes goes for ex 1-2-3-4-3-4-3-2-3-4-5 etc, and the simmilar when turning anticlockwise. It doesent always go in numerical order.
    The fan speed changes in order with the numbers as well so the indicated number is the correct fan speed

    No water ingress from the scuttle area that i can see

    Help me please

    Regards

    Norman

  2. #2
    Regular Member BigP's Avatar
    Join Date
    Apr 2006
    Location
    Heated, Electric Recaro Leather
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Dirty contact?

  3. #3
    Regular Member poves's Avatar
    Join Date
    Dec 2007
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The switch goes fubar I think , best thing is to replace the switch / dial unit.
    It just slides out and terminals unclip.
    They sometimes go on ebay for about £20 - £30 second hand.

  4. #4
    Regular Member
    Join Date
    Apr 2009
    Location
    Redcar
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Nice one

    I never thought for one minute it would be an easy fix like that

    Cheers

  5. #5
    Regular Member poves's Avatar
    Join Date
    Dec 2007
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep , you just slide the storage tray out , then get your fingers behind the unit and it slides out .
    Then disconnect the terminals by sliding the clips up and sideways like a seesaw mechanism.
    Then reverse and it's done , should only take 2 mins literally.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. prob with heater fan speed dial
    By bobk1 in forum Bodywork & Interior
    Replies: 2
    Last Post: 22nd March 2011, 02:31
  2. speed hump prob
    By chris1804 in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 1st November 2010, 21:26
  3. Heater Blower Prob
    By djr69uk in forum Electrical & ICE (including SatNav)
    Replies: 10
    Last Post: 12th July 2010, 23:33
  4. Wierd Climate control problem
    By David2452 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 11th August 2008, 17:06

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •