User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Emissions light/EGR Valve/Air box mod - help

  1. #1
    Regular Member
    Join Date
    Dec 2007
    Location
    North East
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Emissions light/EGR Valve/Air box mod - help

    Can someone please help.
    Recently I removed & cleaned the EGR valve, did the air box mod by removing the piece of plastic. I disonnected the battery for 20mins to reset the system and all was sweet as a nut. The car performed so much better etc etc. I have since done about 700-800 miles without a problem. This week I was driving back from manchester when the dreaded yellow spanner light came on, the car was driving ok. After a while it went off so I dismissed it. Today I was driving up to newcastle and the light came on a again and stayed on till I stopped the car. On starting the car a while later the light briefly came on then went of as normal but the exhaust emission light was illuminated and stayed on for the rest of the journey home.
    Any ideas what could be wrong and is it linked with the egr & air box mod done a while back??
    Any help greatly appreciated.

  2. #2
    Regular Member 67688c's Avatar
    Join Date
    Apr 2008
    Location
    In UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    In case you haven't checked the obvious, certainly worth checking that the plug to the EGR valve has not worked out as its easy to damage the retaining lug inside the plug, it then works its way out, especially as gravity helps it to do so. (ie.plugged in from underneath)

  3. #3
    Regular Member nph1's Avatar
    Join Date
    Apr 2007
    Location
    cheltenham/gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default i had this problem

    hey my friend i had the same problem today, it ended up being the cooling sensor plug to the engine. its a very common fault to a vauxhall this is why you can get a upgrade plug to sort it out just cut the old one off and put this one on and rewire. two min job the plug costs £6
    i put a thread on earler saying emision light problem solved.
    the reasion the emission light is on is because one of the wires has more than likely over heated in the plug.
    good luck
    Last edited by nph1; 2nd May 2009 at 18:29.

  4. #4
    Regular Member
    Join Date
    Dec 2007
    Location
    North East
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by nph1 View Post
    hey my friend i had the same problem today, it ended up being the cooling sensor plug to the engine. its a very common fault to a vauxhall this is why you can get a upgrade plug to sort it out just cut the old one off and put this one on and rewire. two min job the plug costs £6
    i put a thread on earler saying emision light problem solved.
    the reasion the emission light is on is because one of the wires has more than likely over heated in the plug.
    good luck
    where abouts is the cooling sensor plug? and pics would be helpful
    thanks
    Michael

  5. #5
    Regular Member
    Join Date
    Dec 2007
    Location
    North East
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Car is going in to a local garage (non vx) tomorrow morning to try get this problem sorted out, fingers crossed its nothing too major or costly!
    I always hate putting my car in to get problems like this sorted, always fear its gonna cost me a fortune!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. emissions light
    By rick1965 in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 30th December 2010, 23:34
  2. Emissions Light
    By MultiDropper in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 24th December 2010, 23:42
  3. Emissions Light
    By Frp01 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 23rd March 2010, 09:31
  4. emissions light
    By lloyd_456 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 21st September 2009, 09:36
  5. Emissions Light
    By BigKev1970 in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 7th September 2007, 22:16

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •