User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: No 3 injector plug changed but still misfires

  1. #1
    Regular Member
    Join Date
    Aug 2008
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default No 3 injector plug changed but still misfires

    120 cdti had a misfire, particularly when engine hot after stood in traffic, so changed the no. 3 injector plug and soldered wires in. Misfiring still so what do I do now? No EML or warning light. I've ordered 3 more plugs to do the remaining injectors but havent fit yet. Anyone experienced this and know the answer?

  2. #2
    Regular Member vec1975's Avatar
    Join Date
    Feb 2008
    Location
    West Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine misfires slightly when cold and at low revs but seems generally ok the rest of the time. I've had injectors changed, the rail changed, glow plugs changed, loom changed, egr changed and still have it.

  3. #3
    Regular Member
    Join Date
    Aug 2008
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Tried something different and so far so good (touch wood). I took each injector connection off and sprayed WD40 into the plug then connected and disconnected the plug to injector a few times to ensure a good contact. Also made sure each connection was pressed on fully and the yellow locking clip in place, blue one incase of the replaced connector. i started the engine and let it tickover for ages untill it was really hot then had a drive, so far no misfire, fingers crossed, I'm reluctant to start replacing stuff untill I know what the problem is. Will keep you posted.
    This is on a 120 cdti 54 plate with 101k on clock

  4. #4
    Regular Member tankman's Avatar
    Join Date
    Feb 2007
    Location
    NORTHUMBERLAND
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ive got the same thing going on tech 2 says glow plugs need replace so that is going to happen on tuesday but i don't think the misfire will go,my misfire happens when it's hot and not all the time my i put my foot down when it happens it go's off straight away ive got no idea maybe a injector aswell

  5. #5
    Regular Member
    Join Date
    Aug 2008
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Glow plugs I'm sure won't cure it primarily because the engines hot when it misfires and also my glow plugs were changed recently, within the last 1000 miles and still misfired, the misfire on mine only happened when in 2nd or 3rd gear aswell! wierd. Can't see the problem being injectors either with it being such a random and occasional problem.

  6. #6
    Regular Member
    Join Date
    Jul 2009
    Location
    hertforshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Bygumlad....did you replace the 3rd injector plug yourself and if so how hard or easy was it... thinking of fitting mine myself tmoz !!!

    Thanks

  7. #7
    Regular Member
    Join Date
    Aug 2009
    Location
    PERTHSHIRE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default misfire / juddering

    i had a misfire / juddery fault on my 120 cdti. had in and they could not find cause of it on diagnostics but was a fault!!
    so i cleaned egr , no better, changed egr, no better, changed boost sensor, no better. then i just changed the air filter becuase i thought it was a wee bit dirty, and low and behold, car running smooth as anything!!
    only things i touched was air filter housing and took off airflow meter plu and actual airflow meter to get filter out.
    have done over 400miles and is sweet now.
    maybe worth a try??
    Ian

  8. #8
    Full Member Vaux-Man-G's Avatar
    Join Date
    Jul 2007
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I thought the misfire and 3rd Injector issues was only on the 150 CDTI's?

    Seems like its catching..... !


    Bye bye Vec B
    - Hello Siggy!

  9. #9
    Regular Member Thunder's Avatar
    Join Date
    Apr 2008
    Location
    North Yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Facelift

    Trim : Elite

    Engine : CDTi 150

    Year : 2005

    Mileage : 71000

    Default

    It looks like both are affected
    Field Remedy: 2049
    Subject: Engine Z19DT/H - Jerking, somtimes Trouble Code P0201-P0204 set
    Models: Engines: Option:
    Vectra-C 2004...2006,Signum 2004...2006,Astra-H 2004...2006,Zafira-B 2005...2006 Z19DT| Z19DTH| Z19DTL,Z19DT| Z19DTH| Z19DTL,Z19DT| Z19DTH| Z19DTL| Z19DTJ,Z19DT| Z19DTH| Z19DTL
    Complaint: Customer complaint about jerking sometimes SVS lamp on and DTC P0201-P0204 set.
    Cause: Software and / or fretting corrosion on injector plug.
    Production: Modified wiring harness has been implemeted in production as of engine numer: Z19DTH17000444.

    Remedy:
    In case of customer complaint reprogram ECU according TSB 1849 before changing any parts.
    If TSB 1849 will not cure the problem install field fix injector plugs (partnumber 93189918 / cataloguenumber 62 86 769).
    Mentioned Field fix kit does not contain of a 1,5mm² wire as mentioned in TIS 2000 wiring diagram.
    In case of concern please use 2,5mm² instead.
    FunctionalGroup: J - Engine
    Complaint Group: 06 - Failure Code Setting by Control Unit
    Trouble Code: P0201,P0202,P203,P204
    Mine was made after the engine number: Z19DTH17000444
    but i still have yellow plugs but i don't have the problem touchwood

  10. #10
    Regular Member
    Join Date
    Aug 2008
    Location
    preston
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Deano.56,
    Not done the injector change yet, car still misfires but I'm getting use to it, just changed my dual mass flywheel and are going to wait a bit to see if it gets any worse. I beleive also the replacement injector needs programming to the car when fitted (so I'm told) which puts me off doing the job myself as I do not have the facility to do that task. I don't actually think it would solve the misfire anyway after reading some of the threads here. I think the only way to start a thorough investigation is to rig an oscilloscope to each injector in turn and monitor the pulses when driving to see if its an electrical fault or mechanical as at the moment nobody seems to know its just all guesswork.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Injector plug.
    By burbling1 in forum Diesel Engine related
    Replies: 4
    Last Post: 29th July 2012, 12:52
  2. Injector washers changed
    By collyb in forum Engine & Drivetrain
    Replies: 0
    Last Post: 26th April 2011, 21:16
  3. 3rd injector plug
    By neontube in forum Engine & Drivetrain
    Replies: 5
    Last Post: 25th March 2011, 18:26
  4. Those that have changed No.3 injector loom
    By AntSSSS in forum Vectra C / Signum Car Chat
    Replies: 28
    Last Post: 14th February 2009, 20:21

Visitors found this page by searching for:

astra mk5 slight misfire z19dth

Is it easy to replace 3rd injector plug on vectra

z19dth misfire still after changing injectors

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •