User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 2.0 dti unknown fault codes

  1. #1
    Regular Member
    Join Date
    Apr 2009
    Location
    stockton-on-tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2.0 dti unknown fault codes

    alright i have a 2.0 dti vectra and i am having a few problems with it. ive done a diagnostic check on it and it has came back with 3 codes p0070 which was an unknown fault code, p0380 and p0234 one of these was a fault on the turbo and the other is 1 on the glow plugs has any1 came across these faults before and what i can do to fix them and also the car keeps going on to limp mode which i think is to do with the turbo cheers

  2. #2
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    you have a vac leak on the vac system / intake system and you have a faulty glow plug / plugs

  3. #3
    Ex Vec-C Admin & Founder GARY3306's Avatar
    Join Date
    Jun 2005
    Location
    Ashington, Northumberland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    All generic codes
    P0070 = Ambient Air Temp Sensor circuit
    P0380 = Glow plug circuit 'A'
    P0234 = Turbo overboost condition
    [SIGPIC]VX<font color=Red>R</font> with added Courtenay <img src=https://www.vectra-c.com/forum/images/smilies/biggrin.png border=0 alt= title=Big Grin class=inlineimg />

  4. #4
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by GARY3306 View Post
    All generic codes
    P0070 = Ambient Air Temp Sensor circuit
    P0380 = Glow plug circuit 'A'
    P0234 = Turbo overboost condition
    boost preshure sensor on the inlet manifold is either dirty or faulty ...intake air temp and boost presh are all housed in the sensor

  5. #5
    Regular Member
    Join Date
    Apr 2009
    Location
    stockton-on-tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers managed to sort out the turbo it was a vac hose had split seems to be fine now. ive had a quick look at the glow plugs but carnt get the plastic clip off the top of the glow plugs just dont want to rive at them does anyone no how to get them off?? and do you no how i wud sort out P0070 = Ambient Air Temp Sensor circuit cheers people. baz

  6. #6
    Regular Member macdad's Avatar
    Join Date
    Dec 2007
    Location
    East Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Squeze together the two lugs either side of cap and pull,they are usually tight but will come off,don't try the plier method or you'll break em.

  7. #7
    Regular Member
    Join Date
    Apr 2009
    Location
    stockton-on-tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers fella does anyone know how to sort out fault code P0070 = Ambient Air Temp Sensor circuit ?? cheers baz

  8. #8
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    New MAF sensor may be the culprit or maybe the wiring harness could be damaged. Check the connections too for water etc and good connection

  9. #9
    Regular Member
    Join Date
    Apr 2009
    Location
    stockton-on-tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    cheers will let everyone no how i get on

  10. #10
    Regular Member
    Join Date
    Apr 2009
    Location
    stockton-on-tees
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    alright could you tell me where i could find the maf sensor?? and does anyone no where the glow plug relay is ive checked my glow plugs for voltage 3 of them are giving the same reading but carnt get a reading off 1 of them wot else could this be ??? cheers baz

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. unknown fault code
    By Dannyboyjosh in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 27th April 2012, 22:12
  2. unknown fault
    By alexgrfc in forum Engine & Drivetrain
    Replies: 4
    Last Post: 14th August 2009, 21:30
  3. Unknown fault????
    By bigpaw35 in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 2nd August 2009, 19:35
  4. Unknown fault code: P0602 HELP PLS!
    By Woodsta in forum Engine & Drivetrain
    Replies: 10
    Last Post: 3rd January 2008, 16:46

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •