User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: xbox wont work!!!

  1. #1
    Regular Member m3ath3ad's Avatar
    Join Date
    Aug 2007
    Location
    Minehead
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default xbox wont work!!!

    right turned the xbox on and got one red light flashing. its says contact xbox???? its got a code E74 at the bottom of the screen, i bought a new power pack has thought it could be that plugged it but still the red light. it happened after a power cut so dont know if it was a surge or not??

    can anyone help me missing my live playing......

  2. #2
    Administrator Big-Pete's Avatar
    Join Date
    May 2007
    Location
    Home or in the Gym
    Problems Posted
    1
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    93 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Audi Q7

    Trim : S-Line Plus 245

    Engine : 3.0 TDV6

    Year : 2013

    Mileage : 3023

    Default

    My elite had this problem, What i done was call xbox support and told them i had RROD.. They repaired it under warranty for me, They replaced the Motherboard and dvd drive which is the standard fix nowadays.

  3. #3
    Regular Member
    Join Date
    Jan 2009
    Location
    West London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    is it the bottom right red light thats flashing? if so it indicates a hardware error. Could be caused by a faulty AV cable, so if you have a spare or a mate's that you can try. is the machine under warranty?

  4. #4
    Ex Vec-C Admin Deztroyer's Avatar
    Join Date
    Jan 2009
    Location
    WGAF#5
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by m3ath3ad View Post
    right turned the xbox on and got one red light flashing. its says contact xbox???? its got a code E74 at the bottom of the screen, i bought a new power pack has thought it could be that plugged it but still the red light. it happened after a power cut so dont know if it was a surge or not??

    can anyone help me missing my live playing......
    if its under 3 years of age and suffering red ring of death they will repair free of charge

    0-Large smile ......every time it's driven

  5. #5
    Vec-C Facebook Admin thegoldenbullet's Avatar
    Join Date
    Mar 2007
    Location
    Grimsby, Lincs.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    They repaired the E74 for me free of charge mate. But the new box they sent got the RROD 15 minutes after switching it on. the fun destroying **********************

  6. #6
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine did this too, send it back. E74 is the graphics board iirc
    Now I need a turbo to keep up!

  7. #7
    Vec-C Facebook Admin thegoldenbullet's Avatar
    Join Date
    Mar 2007
    Location
    Grimsby, Lincs.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Big Sig View Post
    Mine did this too, send it back. E74 is the graphics board iirc
    its normally caused by an AV chip which is located just behind where the av cables go in. something to do with the AV interfaces between the xbox and tv.

  8. #8
    Regular Member steve0's Avatar
    Join Date
    Mar 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Dont know if they are anygood but if your out of warranty and type in xbox ring of death in ebay there are plenty of auctions apparantly on how-to-fix this.

  9. #9
    Regular Member davree's Avatar
    Join Date
    Jan 2009
    Location
    Warton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRi

    Engine : 2.0 CDTI (160)

    Year : 2010

    Mileage : 26000

    Default

    Quote Originally Posted by steve0 View Post
    Dont know if they are anygood but if your out of warranty and type in xbox ring of death in ebay there are plenty of auctions apparantly on how-to-fix this.
    Its not the RROD fault though, although the RROD can be fixed with 8p!!

  10. #10
    Regular Member m3ath3ad's Avatar
    Join Date
    Aug 2007
    Location
    Minehead
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hmm rite so the best thing it to call xbox support and go from there?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. my heater wont work is it the blower
    By Daz d in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 1st November 2012, 19:30
  2. Keyfob wont work
    By bighammerfan in forum Electrical & ICE (including SatNav)
    Replies: 23
    Last Post: 2nd August 2011, 17:02
  3. Dvd player wont work
    By danny1992 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 4th August 2010, 09:20
  4. New Cd player wont work
    By danny1992 in forum Detailing and Car Care Discussion
    Replies: 3
    Last Post: 26th July 2010, 11:22
  5. Why wont leds work??
    By Danwells72 in forum Styling
    Replies: 13
    Last Post: 1st March 2010, 23:38

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •