User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Tick over 2500 rpm and loss of power

  1. #1
    Regular Member
    Join Date
    Jan 2009
    Location
    Bedford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Tick over 2500 rpm and loss of power

    Hi, new to forum, can anybody help. Parked car up yesterday, returned 8 hours later, started and it run at 2500rpm, with no throttle response, turned of and restarted, still 2500 rpm plus engine management light on. I had to disconnect the battery to reset ECU so I could move the car, so I lost the fault code, but it started and ticked over OK. However now acceleration is poor but ok at high speed. Also noticed a 'hesitation' when cold when accelerator pressed. Joined Green Flag in case. Any advise please?

  2. #2
    Regular Member
    Join Date
    Jan 2009
    Location
    Bedford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    forgot to add it's a 2003 2.2 petrol, also when started from cold some white smoke and petrol smell. Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Wont rev past 2500, no power
    By silvershadow in forum Engine & Drivetrain
    Replies: 2
    Last Post: 7th March 2012, 11:16
  3. black smoke both at tick over and under power
    By aidy-cdti in forum Engine & Drivetrain
    Replies: 9
    Last Post: 23rd July 2011, 14:39
  4. Lumpy tick over and no low end power - Help
    By markluk in forum Engine & Drivetrain
    Replies: 2
    Last Post: 8th June 2009, 07:58
  5. Tick Tick Tick BOOOOM
    By staticbob in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 18th July 2007, 15:42

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •