User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: boost pressure sensor

  1. #1
    Regular Member
    Join Date
    Feb 2009
    Location
    Melton Mowbray
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default boost pressure sensor

    Hi all am new to the site but welcome your advice. My wife owns a veccy 150 cdti ( no particulate filter) but occassionally suffers from what i can only describe as no go at low revs ( below 1600)- hesitation- no matter how much throttle you give it . Then it wakes up an the surge from the turbo kicks in. No smoke at all. If i nail it its fine. But driving normally if i accelerate hard below 1600 nothing happens. Would love to get some ideas and pics of locations of parts to check. Does anyone know where the boost pressure sensor is in the 150 cdti engine ? THe fuel filter been changes 3 weeks ago

  2. #2
    Regular Member mattolly86's Avatar
    Join Date
    Nov 2008
    Location
    oxfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    just above the rad on the right hand side

  3. #3
    Regular Member
    Join Date
    Nov 2008
    Location
    Glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Mattolly86, not sure if you mean the 120bhp model but the boost sensor on mine (150bhp) is on the inlet manifold, held on by a single torx bolt.
    Jim.

  4. #4
    Regular Member keithsimmo's Avatar
    Join Date
    Dec 2007
    Location
    in the engine compartment.
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    This post should be usefull and contains pictures.
    http://www.vectra-c.com/forum/showth...t=72688&page=2

    Last edited by keithsimmo; 22nd March 2009 at 22:29.

  5. #5
    Regular Member MattW's Avatar
    Join Date
    Jul 2008
    Location
    Sheffield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I cleaned mine today, it was solid with soot. Put it back in, and also reset the ECU with the battery off for 30 minutes. Car drives so much better know, it's really suprised me.

  6. #6
    Regular Member Tadpole's Avatar
    Join Date
    Dec 2008
    Location
    'I haven’t lost my marbles, they’re in a bag somewhere? .. '
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by MattW View Post
    I cleaned mine today, it was solid with soot. Put it back in, and also reset the ECU with the battery off for 30 minutes. Car drives so much better know, it's really suprised me.
    Seems to be the answer, keep it clean m8 ........................

  7. #7
    Regular Member
    Join Date
    Feb 2009
    Location
    scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thats the MAP sensor (manifold absolute pressure)

  8. #8
    Regular Member keithsimmo's Avatar
    Join Date
    Dec 2007
    Location
    in the engine compartment.
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    OK, so may be it is ...?

    Where is the Boost sensor then...?

    Picture would help.



    Thanks in advance.

  9. #9
    Regular Member MattW's Avatar
    Join Date
    Jul 2008
    Location
    Sheffield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    That is the Turbo Pressure Sensor (the new Tuning Box from DTUK plugs into that and also controls the boost for the turbo, so I'm going from their Fitment pictures for that information)

  10. #10
    Regular Member
    Join Date
    Feb 2009
    Location
    scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default boost sensor

    according to Autodata, that is the boost sensor. I apologise.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. boost pressure sensor input and output voltage???
    By FLOB in forum Engine & Drivetrain
    Replies: 45
    Last Post: 24th April 2012, 14:58
  2. boost pressure sensor
    By iwtand in forum Engine & Drivetrain
    Replies: 18
    Last Post: 5th February 2012, 20:43
  3. 2.0 dti boost pressure sensor
    By jono m in forum Engine & Drivetrain
    Replies: 2
    Last Post: 3rd January 2011, 12:08
  4. Boost pressure sensor screw thread
    By Godzilla in forum Engine & Drivetrain
    Replies: 4
    Last Post: 5th June 2010, 20:59
  5. Boost Pressure Sensor
    By vectravirg in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 15th November 2007, 12:52

Visitors found this page by searching for:

vectra dti boost pressure sensor location

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •