User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Intermittent Cruise Control Problem

  1. #1
    Regular Member Bobarache's Avatar
    Join Date
    Jan 2009
    Location
    Perth, Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Intermittent Cruise Control Problem

    Every now and again I have a problem with my cruise control, if I disable it and then try to enable it again it won't switch back on.
    The only way to get it to enable is to switch off the ignition and turn it back on.

    My brother-inlaw has an 06 CDXI Vectra and he has had the same problem from time to time.

    Am wondering if this is a common fault in Vectra's, am interested if anyone else has the same intermittent problem.

  2. #2
    Ex Vec-C Admin ed taylor's Avatar
    Join Date
    Oct 2005
    Location
    Looking Through a Camera Lens.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra Estate

    Trim : Elite

    Engine : 3.2 V6

    Year : 04

    Mileage : 000

    Default

    Might be the spring on the clutch pedal.

  3. #3
    Full Member neverlandandy's Avatar
    Join Date
    Sep 2006
    Location
    lanark
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Elite Nav

    Trim : Elite

    Engine : 2.0 cdti

    Year : 2012

    Mileage : 9k

    Default

    Quote Originally Posted by ed taylor View Post
    Might be the spring on the clutch pedal.

    aye have you tried to put your foot under the clutch pedal and just give it a gentle little pull that usualy works

  4. #4
    Regular Member Phil MC's Avatar
    Join Date
    Oct 2008
    Location
    Kirkie
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The three things I've encountered during my ownership of three different Vectra C's are:

    1) Clutch pedal switch- give pedal a tap and then re-try to engage.
    2) Brake pedal switch - give pedal a tap and then re-try to engage.
    3) If there's an underlying defect that your ECU is picking up on then depending on the fault it can inhibit the Cruise Control engagement - try a fault code read to see if there is a code present and try to clear it.

    Good luck,

    Phil C

  5. #5
    Regular Member andymagee1982's Avatar
    Join Date
    May 2008
    Location
    Widnes.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Bobarache View Post
    Every now and again I have a problem with my cruise control, if I disable it and then try to enable it again it won't switch back on.
    The only way to get it to enable is to switch off the ignition and turn it back on.

    My brother-inlaw has an 06 CDXI Vectra and he has had the same problem from time to time.

    Am wondering if this is a common fault in Vectra's, am interested if anyone else has the same intermittent problem.

    Yep me to.
    If I hit the slow down button it goes off untill I restart the car.
    If I hit the Cancel button it goes off but I can re set it

    Tryed all the clutch and brake things with no luck!

  6. #6
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    Dirty stalk switch connections?? Contact spray and rapid switching to clean - worked for mine.

  7. #7
    Regular Member
    Join Date
    Jan 2007
    Location
    Chelmsford
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I agree with ste, the buttons are a bit rubbish and get bunged up easily.

    I have a problem with mine sometimes. The cruise won't activate unless I press the button really hard.

  8. #8
    Regular Member Bobarache's Avatar
    Join Date
    Jan 2009
    Location
    Perth, Australia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by andymagee1982 View Post
    Yep me to.
    If I hit the slow down button it goes off untill I restart the car.
    If I hit the Cancel button it goes off but I can re set it

    Tryed all the clutch and brake things with no luck!

    Does that happen everytime or only now and again ?

    Cheers guys....I will give them all a try, it is a bit of a pain in the ass to fault find as it only happens now and again.

  9. #9
    Regular Member andymagee1982's Avatar
    Join Date
    May 2008
    Location
    Widnes.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It does it all the time.

    No codes on mine

  10. #10
    Regular Member
    Join Date
    Mar 2008
    Location
    slough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi people i have a problem with the cruise control on my 56 plate vectra c ,it intermitantly switches off i have replaced the control arm, the clutch switch the brake switch the throttle pedal complete and it still dose it, im tieing a noose at the moment so please for give me if i dont reply for some time. thanx guys. sad man............

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Intermittent cruise control & oil can light...HELP NEEDED
    By simmo3187 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 12th July 2012, 14:06
  2. Another Cruise control Problem
    By Nezza42 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 16th June 2012, 16:20
  3. sorry another cruise control problem
    By david.mann8 in forum Vectra C / Signum Car Chat
    Replies: 15
    Last Post: 15th June 2012, 15:35
  4. Cruise control intermittent working, ( faulty CIM possible?)
    By jon1.9cdti in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 3rd June 2012, 23:32
  5. Cruise control problem
    By r.bailey63 in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 25th March 2007, 20:26

Visitors found this page by searching for:

vectra c cruise control intermittent

https:www.vectra-c.comforumshowthread.php74377-Intermittent-Cruise-Control-Problempage2

my vectra cruise control disables

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •