User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: help changing indicator stalk

  1. #1
    Regular Member crucial's Avatar
    Join Date
    Oct 2007
    Location
    kent
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default help changing indicator stalk

    I am trying to get the indicator/cruise control stalk out of my 2003 vectra c, anyone know how the thing comes out? Need to change it because my cruise control switch has stopped working. Thanks.

  2. #2
    Regular Member glynn's Avatar
    Join Date
    Apr 2007
    Location
    stevenage, hertfordshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    i belive you just twist it slightly then pull it out, have you had it tech 2 as there is a switch on the clutch and break pedals

  3. #3
    Regular Member crucial's Avatar
    Join Date
    Oct 2007
    Location
    kent
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    seems to be the indicator stalk thats faulty, when i switch the rocker downwards to slow the cruise speed down it just switches off and the cruise cant be activated again unless the car is switched off then back on again, this seems to reset it , so im guessing it must be that switch on the end of the stalk, that is unless you know otherwise.

  4. #4
    Regular Member Turbo Gav's Avatar
    Join Date
    Mar 2009
    Location
    Huntingdon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Don't think it turns the speed down its the resume/stop button or at least thats how mine works. If you want to slow down just tap the bottom one and then reset the speed lower.

  5. #5
    Admin & Merchandise Manager bigmac's Avatar
    Join Date
    Jul 2008
    Location
    Devon
    Post Thanks / Like
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    46 Post(s)
    Tagged
    0 Thread(s)

    Default

    You just pull the rubber grommet out of the cowling then pull the stalk outwards,that's it dont be afraid on pulling to hard just grab it and pull HTH

  6. #6
    Regular Member aerodynamic18's Avatar
    Join Date
    Aug 2007
    Location
    Lisburn, N.Ireland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    on mine when you press the bottom one with the cruise activated it does slow down but with the cruise deactivated it acts as the resume button. hth

  7. #7
    Regular Member Ben999's Avatar
    Join Date
    Feb 2009
    Location
    Milton keynes
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    When the cruise control is activated, the bottom one 'sets' the speed. Then at any time when not activated if you press the bottom one it either speeds the car up, or slows it down to that set speed.

    Or at least thats how it works on mine.

  8. #8
    Regular Member KieronGSI's Avatar
    Join Date
    Apr 2008
    Location
    Aylesbury
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by crucial View Post
    seems to be the indicator stalk thats faulty, when i switch the rocker downwards to slow the cruise speed down it just switches off and the cruise cant be activated again unless the car is switched off then back on again, this seems to reset it , so im guessing it must be that switch on the end of the stalk, that is unless you know otherwise.

    Mine has exactly those symptoms i just end up turning it off and letting the speed drop off then re-activate if i need to slow down.

    Let me know how you get on!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Indicator Stalk dilemma !!
    By jagz21 in forum Troubleshooting
    Replies: 6
    Last Post: 2nd March 2011, 17:24
  2. preface indicator stalk
    By leesri in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 30th December 2010, 16:47
  3. New indicator stalk
    By j1 wyx in forum Parts for sale
    Replies: 0
    Last Post: 13th June 2010, 10:25
  4. Indicator stalk
    By old cruiser in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 2nd October 2009, 13:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •