User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Turbo Problem

  1. #1
    Regular Member sberrow's Avatar
    Join Date
    Jul 2008
    Location
    Newport (Gwent)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Turbo Problem

    After having the problem on the rr i have been fussing about trying to find what was wrong. Just had the exhaust off and the mechanic says 'there is a damaged fin'???? Didnt pick the car up my self dont have a clue what he is on about. be a few hours before i can speak to him but do any of you have any ideas

  2. #2
    Regular Member Ste's Avatar
    Join Date
    Jul 2005
    Location
    ..... Driving the Jaguar XF
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Jaguar XF 3.0D V6

    Trim : Black

    Engine : 3.0D V6

    Year : 0000

    Default

    Does he mean a turbo blade? If there was significant damage to a turbine blade, the turbo would be well out of balance and would probably destroy itself fairly smartish.

  3. #3
    Regular Member sberrow's Avatar
    Join Date
    Jul 2008
    Location
    Newport (Gwent)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    dont know will def find out later

  4. #4
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    (Ste) If one of the turbine blades was badly damaged you're know about it very quickly.

    Which side does he say it's damaged on? compressor or exhaust?- and what is the actual damage?

    It's very unusual for an exhaust turbine blade to get damaged - unless you've got bits coming loose in the engine! - it's normally the compressor (intake) blades that get any damage, usually by people removing the stock airbox/filter and fitting aftermarket ones that have coarser filters and therefore allow larger foreign bodies through.

  5. #5
    Regular Member sberrow's Avatar
    Join Date
    Jul 2008
    Location
    Newport (Gwent)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    exhaust side, had a rear bump before christmas, exhaust was hit hard and pushed forward, exhaust was fixed and tubro fixed, starting to doubt the company that fixed it. in the bump it sheared the bolts to the exaust and come on the turbo. whole thing was pushed onto the engine. starting to think they may have retapped the bolts and give it a clean and polish and refitted it??

  6. #6
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ah, that information changes things - it must've been a helluva shunt to have transmitted all that energy right to the turbo/exhaust connection and shear it!!

    Can't see how the blades could be damaged specifically by the shunt from the exhaust though - the turbine is set back quite a bit from where the exhaust attaches......



    I reckon what's happened is that bits of debris have gone into the exhaust side when the bolts have sheared etc. and hit the turbine then, or subsequently. What exactly did the company do when they 'repaired' the turbo?

  7. #7
    Regular Member sberrow's Avatar
    Join Date
    Jul 2008
    Location
    Newport (Gwent)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Do you have a pic of the above view of the turbo and ill mark what was damaged.They were supposed to send it to turbo technics to have it over haulled, Never went, i think they unbolted it retapped the bolts in the pic and one the other side, give it a clean and put it back on.. insurance company was charged 990inc vat for their trouble

  8. #8
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by sberrow View Post
    Do you have a pic of the above view of the turbo..
    Waddya mean? Can you not save that pic and use it? or do you need a different view of the turbo?
    Quote Originally Posted by sberrow View Post
    They were supposed to send it to turbo technics to have it over haulled,
    Well if it did you'd have got documentation from TT with the warranty they give.
    Quote Originally Posted by sberrow View Post
    .. insurance company was charged 990inc vat for their trouble
    For what? Just the turbo 'refurb'? TT only charge around £300 all in for a full bearing and seal service!

  9. #9
    Regular Member sberrow's Avatar
    Join Date
    Jul 2008
    Location
    Newport (Gwent)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I know i spoke to them myself and they told me rough costs,they couldnt tell me for sure but they dont think it went in to them. i was after another view of the turbo.
    They insurance bill says a NEW turbo Fitted!!! def not its the old one

  10. #10
    Regular Member sberrow's Avatar
    Join Date
    Jul 2008
    Location
    Newport (Gwent)
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Oh by the way they company is gone, units empty, just my luck

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.2 dti Turbo problem
    By Shortland78 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 18th February 2011, 14:34
  2. 2.0 Turbo problem
    By the stig in forum Engine & Drivetrain
    Replies: 7
    Last Post: 4th March 2010, 20:31
  3. problem with turbo or ?
    By chikenbud in forum Engine & Drivetrain
    Replies: 3
    Last Post: 1st February 2009, 16:03
  4. Turbo Problem...
    By dankidd in forum Engine & Drivetrain
    Replies: 3
    Last Post: 11th August 2008, 22:55
  5. 2.0 DTI turbo problem
    By Vibez_Uk in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 19th March 2008, 21:15

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •