User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Anyone with a Z20NET...(2.0T)

  1. #1
    Regular Member n_hudson's Avatar
    Join Date
    Mar 2008
    Location
    Northampton, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Anyone with a Z20NET...(2.0T)

    Had the Poly-V-belt Pully rattle? Someone, I think Signumboy had this problem, has anyone else had this problem? I've had so much done to the car to get rid of the stupid rattle, this has got to be the last option, although it was one of the first given on here (Doh!). Anyone had it replaced, repaired, upgraded or what ever they do? Cost?

  2. #2
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Do a search nick as there's a bunch of threads on it - including several posts by me. Search for things like alternator pulley for one and twittering.

    It's a common thing on the 2.0T.

  3. #3
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    http://www.vectra-c.com/forum/showthread.php?t=38678

    There - that'll get you started.

  4. #4
    Regular Member n_hudson's Avatar
    Join Date
    Mar 2008
    Location
    Northampton, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep, found them now Duncan, thanks for that! The cars in getting the steering rack sorted, upper control arms and new springs fitted... Dreading the final cost! Gulp (Not brave enough to do it myself - Not after the hassle I had with my drop links - LOL)
    Guess I'd better add that to it now!

    Bye Bye Bonus... I will get that new exhaust and remap one day LOL.

  5. #5
    Regular Member andy76's Avatar
    Join Date
    Dec 2008
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : cdti 150

    Trim : sri

    Engine : z19dth

    Year : 2005

    Default

    i have twittering on my 2.0T, it does it for about 20 mins then stops. i thought i was the cam kit that needed changing (i think its called that) had it changed on every other vec.
    so it's the altanator pully, anyone got a price for this to be sorted.

  6. #6
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The modified alternator pulley is around £90/£100 from memory -plus time to fit. Depends if you were thinking of doing yourself?

  7. #7
    Regular Member n_hudson's Avatar
    Join Date
    Mar 2008
    Location
    Northampton, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Doing it yourself!? Are you mad?! LOL

  8. #8
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. z20net
    By sri-100 in forum Engine & Drivetrain
    Replies: 33
    Last Post: 6th November 2012, 22:05
  2. z20net mpg
    By james23 in forum Vectra C / Signum Car Chat
    Replies: 25
    Last Post: 24th July 2012, 11:30
  3. z20net
    By garys362 in forum Tuning
    Replies: 3
    Last Post: 29th April 2011, 21:36
  4. Z20net
    By FIL 4822 in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 21st April 2011, 09:56

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •