User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: urgent help needed!

  1. #1
    Full Member VectraMat's Avatar
    Join Date
    Oct 2005
    Location
    Hull
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default urgent help needed!

    Hi guys. I'm just driving home from my gf's place but there's something wrong with my vectra.. I've driven about 10 miles now but the engine temp dial hasn't moved at all. The heater has warmed up but isn't as hot as it should be. Does anyone know what the problem might be. Thanks. Matt.

    VXR Gone - Now in BMW 320cd M Sport Convertible

  2. #2
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Sounds like thermostat mate.

  3. #3
    Full Member VectraMat's Avatar
    Join Date
    Oct 2005
    Location
    Hull
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by rushy View Post
    Sounds like thermostat mate.
    Is this a big/expensive job mate? Cheers for the above btw.

    VXR Gone - Now in BMW 320cd M Sport Convertible

  4. #4
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    TBH, never done one on the Vec. In the past on other lumps its just undo two bolts, pop out thermostat and pop in a new one, plus draining and refilling coolant.

  5. #5
    Full Member VectraMat's Avatar
    Join Date
    Oct 2005
    Location
    Hull
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers rushy, might have to spend tomorrow night investigating this then. Ta mate!

    VXR Gone - Now in BMW 320cd M Sport Convertible

  6. #6
    Regular Member mattolly86's Avatar
    Join Date
    Nov 2008
    Location
    oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i've not done it on a veccy but i would be seriously suprised if more than 4 bolts involved

  7. #7
    Regular Member rushy's Avatar
    Join Date
    Jul 2005
    Location
    Old School Vectra-C.Com. Residing in sunny Leeds.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRi


    Engine : Z22SE (2.2 Petrol)

    Year : 2004

    Mileage : 137000

    Default

    Any noises mate? Could be the pump also, but that's a bit more involved. Thermostat should cost you no more than £40 for labour at any half decant independent. You'll still be under warranty won't you? The thermostats i've done in the past are usually in a metal pipe that comes of the lump. You unbolt the pipe and the thermostat is just inside and will fall out. Totally different cars but the principle will be the same. Pop it in a pan of water and it should open about 85-90 degrees, if not its broken.
    Last edited by ukanalyst; 17th March 2009 at 22:09. Reason: Language Cleaned Up

  8. #8
    Regular Member RhayaderSax's Avatar
    Join Date
    Sep 2008
    Location
    Rhayader
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep - I agree. Sounds like thermostat. Replaced them on Cavalier A & B. If Vx design & manufacture is still similar if you do it yourself for god sake use a torque wrench. Casting typically held on with 2 bolts & the flange is the weak point. Over-tighten the bolts & the casting that the thermostat fits inside will crack.

  9. #9
    Ex-Staff Full Member Taffyopel's Avatar
    Join Date
    Oct 2007
    Location
    Horley, Surrey
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This is standard on the 1.8's!

    Mine is exactly the same and if you do a search, numerous members have had the same issue.

    9 times out of 10 a new thermostat cures the problem.


    Snowman, you got your ears on?

  10. #10
    Regular Member dlm71's Avatar
    Join Date
    Feb 2009
    Location
    Cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have the 1.8 vvt SRI and mine does the same! just never got around to sorting it!! it won't move for 10 mins or so then it will shoot up to it's running temp!!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. urgent help needed.
    By adierolfe in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 25th June 2012, 09:53
  2. URGENT help needed
    By vectraedition100 in forum Engine & Drivetrain
    Replies: 12
    Last Post: 27th February 2012, 20:21
  3. urgent help needed?
    By webber446 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 11th January 2012, 14:30
  4. urgent help needed >>>>>>
    By justin79 in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 11th August 2011, 20:02

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •