User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Fault code P2279?

  1. #1
    Regular Member Phil MC's Avatar
    Join Date
    Oct 2008
    Location
    Kirkie
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Fault code P2279?

    Hi and thanks for reading this.

    My 56 plate Vectra Design 1.9 CDTi 150 has in the last day or so developed a fault with the following symptoms:

    1) Only during acceleration around 2,000rpm or above when the turbo is kicking in the spanner light comes on (Code P2279) and the turbo is totally inactive. i.e. very flat even if accelator to the floor it will slowly climb in rpm without the turbo kicking in again.

    2) After about 10 seconds with the accelerator in an idle postion and the revs dropped to below the turbo range the spanner extinguishes and I'm able to drive it normally again for a short while, and then the turbo appears to stop working and anorther spanner light.

    Fault code P2279 is "Intake air sys leak".

    I had a previous SRi150 with a spanner light fault code P0400, which was the Intake Manifold, but during that defect above 2-2500rpm the engine still went like sh*t off a shovel, so hopefully I can rule that out?

    I've tried the following today unsuccesfully:

    1) Check of Air intake system - All satis.
    2) Umplugged MAF to see if symptoms persisted - Came up with MAF fault code immediately, so not that.
    3) Removed and cleaned the Boost Sensor - Still the same.
    4) Removed and cleaned the EGR Valve - Still the same.

    It seems to me to be either the Turbo itself or a sensor used by the turbo??

    Does anyone else have any thoughts on what it could be, or has anyone else had the same problems? If so, what cured yours?

    Cheers for looking,

    Phil C

  2. #2
    Full Member
    Join Date
    Nov 2008
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi this is what the code come up as.

    The control unit recognises a mechanical malfunction of the following component via an internal evaluation logic:
    Intake system

    I think this may be a job for ther stealers. But check all your vacume pipes first . and also all pipes to inlet.

  3. #3
    Regular Member Phil MC's Avatar
    Join Date
    Oct 2008
    Location
    Kirkie
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers SB1.

    I'll get another look at all of the pipes around the rear at the manifold area tomorrow in the daylight.
    Last edited by Phil MC; 8th March 2009 at 19:12.

  4. #4
    Regular Member
    Join Date
    Oct 2007
    Location
    estonia
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I`d say 80% of P2279 = EGR fault. Unless you find a leak in intake side replace it and you should be OK.

  5. #5
    Regular Member Phil MC's Avatar
    Join Date
    Oct 2008
    Location
    Kirkie
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers Gaz.

    What I'll do tomorrow is double check all of my hoses and connections and then replace the EGR valve with the spare one I have left over from when I was fault-finding my old SRi150. I'll drill the hole and fully disassemble it for a thorough overhaul before fitment.

    I'll post my findings after I've done this work.

    Phil C

  6. #6
    Regular Member Phil MC's Avatar
    Join Date
    Oct 2008
    Location
    Kirkie
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    On my way to work last night the symptoms changed ever so slightly.

    The spanner light came on whilst accelerarting using the turbo at about 2,500rpm, but this time the turbo never dropped out and the engine continued to operate in a satisfactory manner.

    I got to work and checked the fault codes and lo and behold the P2279 has now been joined by P0400 (EGR Fault).

    Today I did the complete strip and overhaul of the EGR Valve solenoid section (PDF guide attached) and found that it was quite sticky in its operation beforehand. After cleaning off the corrosion and lubricating the components it is such an easy and freely operating solenoid that I'm keeping my fingers crossed that this has been the cause of the fault indications.

    I gave the car a quick blast over the same route that I've been testing it over the last few days and it never failed.

    I'll give it a really good test over the next day or so and report back to let you know how I get on.

    Phil C

  7. #7
    Regular Member keithsimmo's Avatar
    Join Date
    Dec 2007
    Location
    in the engine compartment.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Me too

    I followed the same guide today and it has also resolved my issues, feels like a new car again.

    I had the same error code.

    You really do need to strip the Solenoid side of the EGR to resolve this issue. Only took an hour so well worth it.

  8. #8
    Regular Member Phil MC's Avatar
    Join Date
    Oct 2008
    Location
    Kirkie
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Cheers Keith,

    i've just posted similarly on your thread that is running alonside mine....pmsl!!!

    Great minds think alike .

    After a damn good 100 mile journey to work tonight (Usually 20 miles, but wanted to give it a good test), I can reveal that this EGR Valve solenoid strip and clean HAS SORTED this problem .

    Many thanks to all for helping out.

    Phil C

  9. #9
    Regular Member keithsimmo's Avatar
    Join Date
    Dec 2007
    Location
    in the engine compartment.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Congratulations

    Glad that you have it sorted and that it's going to last.

    I only tested around the block tonight but could tell that it had resolved it in the first 10 meters.

    Hopefully I wont be stuck racing Trucks up hills tomorrow morning on the way to work a 60 mile round trip. lol


  10. #10
    New Member
    Join Date
    Oct 2009
    Location
    Herts
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine had the same error code today. Was so dissapointed, as I only bought it last week.

    Will have a look at the EGR valve...thanks

    Apparently, you can add stuff in your fuel tank to clean the system - anyone know if this is any good or what it's called?

    Goose

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. P2279 Fault Code - Ait Intake Leak
    By McLovinH in forum Engine & Drivetrain
    Replies: 27
    Last Post: 20th September 2012, 17:54
  2. 1.9 CDTI fault code P2279-11
    By mozzer99 in forum Engine & Drivetrain
    Replies: 42
    Last Post: 14th June 2011, 20:13
  3. P2279 code. 1.9 150
    By Mopar Man in forum Diesel Engine related
    Replies: 32
    Last Post: 28th April 2011, 20:45
  4. fault code p2279
    By decks in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 20th November 2010, 20:14
  5. Fault code P2279 Showing.HELP!!!.Info PLEASE.
    By felixx in forum Engine & Drivetrain
    Replies: 7
    Last Post: 28th October 2010, 18:34

Visitors found this page by searching for:

p2279 fault code www.vectra-c.com

vectra 1.9 cdti 2279 fault

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •