User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 10 of 10

Thread: Vectra 1.9 cdti 120 with no power.

  1. #1
    Regular Member
    Join Date
    Dec 2006
    Location
    glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Vectra 1.9 cdti 120 with no power.

    I have done a search on here and some of my symptoms are explained, but not in a specific way for my engine.

    My problem is this, I dont have any power or grunt from my engine, as if driving without the turbo kicking in. I dont think it is in limp/safe mode as it does drive OK and wil accelerate up to and beyond 70 mph. Most of the fixes I have come accross seem to refer to the 150 bhp engine. Any suggestions as to what could be wrong with my 120 bhp. It is having a service tomorrow but I dont think that will affect this problem.


  2. #2
    Regular Member John35's Avatar
    Join Date
    Jun 2007
    Location
    in a white box
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    There's no real difference to the 150 engine apart for 8 more valves. If the fixes you have found relate to the 150 then they probably relate to the 120.

  3. #3
    Regular Member
    Join Date
    Feb 2007
    Location
    North west
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    EGR valve

  4. #4
    Regular Member
    Join Date
    Dec 2006
    Location
    glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks for the quick response.

    It was bacause of this and similar comments that I thought there may be a different diagnosis for each engine.

    Quote "120 or 150 bhp ? could be stuck swirl valve if its a 150. Try a flush dose of redex, cleaning the EGR is easy mate, it restored my CDTI to its former torque heaven"

    Is there a "How to" on how to tackle the EGR valve?

  5. #5
    Regular Member John35's Avatar
    Join Date
    Jun 2007
    Location
    in a white box
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    120's do not have swirl valves...thank goodness... here's the link to cleaning the EGR www.vectra-c.com/forum/showthread.php?t=45867 . Located on top of the engine near the windscreen http://www.vectra-c.com/forum/showthread.php?t=30759

  6. #6
    Regular Member
    Join Date
    Dec 2006
    Location
    glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thanks for that. I have just read through the How to and hopefully will try this next weekend.


  7. #7
    Regular Member keithsimmo's Avatar
    Join Date
    Dec 2007
    Location
    in the engine compartment.
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default How 2

    Quote Originally Posted by John35 View Post
    120's do not have swirl valves...thank goodness... here's the link to cleaning the EGR www.vectra-c.com/forum/showthread.php?t=45867 . Located on top of the engine near the windscreen http://www.vectra-c.com/forum/showthread.php?t=30759

    That really needs to be moved to the How 2 section.

    I have hope again of fixing my issue thanks to a little reading of this site. I have done the cleaning of the easy end but will clean the solenoid end next.
    http://www.vectra-c.com/forum/showth...t=45867&page=6

  8. #8
    Regular Member silverhairedracer's Avatar
    Join Date
    Jan 2007
    Location
    ESSEX
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Check for split pipes,my problem was sorted all due to a perished pipe on the vac pipe to the wastegate,pipe is on front of engine r/h side about 3 mm dia.part no 55556072.

  9. #9
    Regular Member
    Join Date
    Dec 2006
    Location
    glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I finally got round to removing and cleaning my EGR valve today, put it all back together, and.... Hey Presto back in torque heaven. So once again guys thanks for all your advice and help.


  10. #10
    Regular Member Tadpole's Avatar
    Join Date
    Dec 2008
    Location
    'I haven’t lost my marbles, they’re in a bag somewhere? .. '
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Pleased to hear you had a good result m8 ..................

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help!!!Vectra 05 1.9 SRI CDTI power problem!
    By sohail1989 in forum Troubleshooting
    Replies: 5
    Last Post: 18th November 2012, 00:32
  2. Power Loss Vectra V6 3.0 CDTI
    By renwich in forum Y & Z30DT Specific
    Replies: 32
    Last Post: 7th September 2011, 22:52
  3. Vectra c 3.0 cdti ( loss of power )
    By dshelton999 in forum Engine & Drivetrain
    Replies: 22
    Last Post: 22nd June 2011, 20:58
  4. Help with Vectra CDTI SRI 150 - Car loss of power
    By dan912 in forum Troubleshooting
    Replies: 2
    Last Post: 27th May 2011, 08:59
  5. How do you get more power out of a vectra cdti 120?
    By Pdvectrasri in forum Diesel Engine related
    Replies: 15
    Last Post: 11th April 2010, 20:01

Visitors found this page by searching for:

power loss on vectra 1.9 tdi

vectra c lacking power

vectra 120 loss of power

vauxhall vectra 1.9 cdti no power

vectra with no power

05 vectra 1.9tdi no power

1.9cdti 120 no boost

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •