User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: 1.9 CDTi SRi (150) "Lag"??

  1. #1
    Regular Member
    Join Date
    Dec 2007
    Location
    North East
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 1.9 CDTi SRi (150) "Lag"??

    I have noticed recently that when I start my car from cold and set off there seems to be some "lag" before it gets going, this can be a bit of a problem at junctions and roundabouts when I need to get out quick. Eventually the turbo kicks in and it does go but its that initial start when I can have the pedal flat down and it makes no difference. It doesn't seem as bad when the car is up to temp.
    Is this normal and just down to the cold weather???
    Michael

  2. #2
    Regular Member Big Knox's Avatar
    Join Date
    Feb 2009
    Location
    Edinburgh
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    think the car won't give you all it's power until the engine has warmed up, even more so in really cold mornings.

  3. #3
    Regular Member aerodynamic18's Avatar
    Join Date
    Aug 2007
    Location
    Lisburn, N.Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yep what knoxvillain said mine does the same

  4. #4
    Regular Member
    Join Date
    Feb 2007
    Location
    North west
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    EGR valve 100% mate, just what mine was doing. So sluggish when cold its dangerous until you hit about 2500 rpm.

    1 - 2 hour job very easy. Get some Wynns carb cleaner from Halfrauds and let it soak. I had time to remove and clean air box while EGR was soaking. Activate the valve by pushing the metal plunger by hand while cleaning / spraying the wynns.

    Car back to its best 1 hour later. I have done this twice now. Both times I got an EM light shortly after which went off after about 2 days and did not re light. I also put redex into the fuel to flush out the swirl valves / inlet manifold. Could be that set off the EM light, but either way car is much better after the clean up.

  5. #5
    Regular Member
    Join Date
    Dec 2007
    Location
    North East
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by rob 2.2dti View Post
    EGR valve 100% mate, just what mine was doing. So sluggish when cold its dangerous until you hit about 2500 rpm.

    1 - 2 hour job very easy. Get some Wynns carb cleaner from Halfrauds and let it soak. I had time to remove and clean air box while EGR was soaking. Activate the valve by pushing the metal plunger by hand while cleaning / spraying the wynns.

    Car back to its best 1 hour later. I have done this twice now. Both times I got an EM light shortly after which went off after about 2 days and did not re light. I also put redex into the fuel to flush out the swirl valves / inlet manifold. Could be that set off the EM light, but either way car is much better after the clean up.
    To be honest I am totally cluless with car mechanics and letting me loose on mechanical work would be VERY dangerous!

    I did think about putting some injector cleaner in the fuel but thats probably my limit!

    I wonder if I should get it in the garage?

    Michael

  6. #6
    Ex Vec-C Admin Stevel's Avatar
    Join Date
    Nov 2006
    Location
    Chester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    What Rob said.

    You don't get full power when cold but with your foot flat to th floor it will still be quick. Those symptoms are exactly what mine was like when the EGR valve went.

  7. #7
    Regular Member
    Join Date
    Feb 2007
    Location
    North west
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If you follow the how too on here you can do it. I would rate it as a very easy job. If you can wire a plug or change a wheel you can do this.

    Perhaps there is a member who can show you in the NE ? Im up for it if you fancy a trip to the NW and I have a garage.

  8. #8
    Regular Member
    Join Date
    Dec 2007
    Location
    North East
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Rob thanks for the kind offer of help however it's not that feasible for me to comer over to the NW at the mo

    Is this the how 2 - http://www.vectra-c.com/forum/showthread.php?t=39441

    Where would i get the new gaskets from?
    I'm sure I have read on this forum that cleaning the EGR valve doesn't really work and it needs replacing with a new one, Is this true?

  9. #9
    VIP-Member MCD's Avatar
    Join Date
    Apr 2007
    Location
    Romiley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 2007 Vectra

    Trim : SRi XP Saphirre Black

    Engine : 2.0 16v Turbo

    Year : 2007

    Mileage : 60k

    Default

    Mine also does this from cold, usually pulling out the top of our road! However if i hold the revs higher i can fire out fine!

    However, to my mind, i shouldnt be driving a car hard when its cold in any event! So i just chill and dawdel till its warmed up!

    Mike


    Noobtune 220bhp / 270lb - (07) 2.0 turbo SRi XP NAV - PLUS SUNROOF!

  10. #10
    Regular Member
    Join Date
    Feb 2007
    Location
    North west
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yes thats the how too. I replaced the gaskets I took out, they are soft metal and cleaned up with the wynns. I believe there is now a gasket that covers up most of the valve opening restricting the amount of gas that passes through. Might get round to fitting one if I have to clean the valve again. First time I did it I didnt have the carb cleaner (Wynns) so i used wd40 and white spirit and it only did half a job. I obviously had to dry it completely after this or risk damaging the oxygen sensor. I can say from experience that the Wynns really does the business, loads more carbon crud cleared and valve looks like new metal when done.

    MCD if you fancy giving it a clean Im in Warrington, absolute max 2 hour job if you want to call over. Really transforms car. If you leave it it gets worse...

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 23
    Last Post: 17th November 2012, 23:49
  2. "Winter" Wheels ? Are 19" Snowies best for the "Summer" ?
    By Woody in forum Vectra C / Signum Car Chat
    Replies: 21
    Last Post: 5th October 2012, 18:43
  3. 3.0 cdti y30dt automatic "leaking" coolant
    By Maggie in forum Engine & Drivetrain
    Replies: 2
    Last Post: 13th October 2011, 21:29
  4. Replies: 17
    Last Post: 15th December 2009, 14:53

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •