User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Spanner Light

  1. #1
    Regular Member
    Join Date
    Sep 2008
    Location
    Somerset
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Spanner Light

    Hi Guys,

    I have got the dreaded spanner light on still on my car (Vectra 2002 DTI 2.0), and i today purchased the VauxCheck software and connected it up to see whats wrong.

    THe only code i got back was:

    BODY{font:10pt Tahoma, Verdana, sans-serif;}'P1604 - Stored - Engine control Module (ECM) - defective'

    Does this mean the main ecu is not working? The car still drives/starts perfectly, just with the spanner light on it is in limp mode!

    Or could it be VauxCheck not communicating with the car properly.

    If it is the ECM how much would that cost?!!

  2. #2
    Regular Member
    Join Date
    Sep 2007
    Location
    Nottinghamshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Perhaps worth contacting Gendan to see if they can shed any light regarding whether there could be any issues with this code for your specific age/model of engine?

    I suppose the thing about fault code readers is that they tell you the error code, but it's then up to you to diagnose it.

    It may come up with something very specific and definite but if it comes up with something more generic or expensive like this, you have to decide whether to just replace the module in question (and it may still need coding in via Tech2 at a dealers) or take the car to an expert who might be able to confirm or check out some related items e.g. sensors.

  3. #3
    Regular Member slipperysam1984's Avatar
    Join Date
    Apr 2009
    Location
    Bournemouth
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi,

    i had the same code when i done my check. i cleared it down with my opcom.
    has never come back.

    if i remember i also disconnected the battery after clearing the code down. just for luck.

    sam

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Problems with Air bag light, ABS, Anti Skid & Spanner light
    By WeDesign in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 4th December 2012, 21:23
  3. Should I Have A Spanner Light aswell as an Engine Light on My Signum?
    By StreetDragster in forum Engine & Drivetrain
    Replies: 16
    Last Post: 18th August 2012, 11:57
  4. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  5. spanner light then engine management light
    By learoy69 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 12th March 2010, 20:10

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •