User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: What do i get myself into?

  1. #1
    Regular Member Jackvectra18's Avatar
    Join Date
    Jan 2009
    Location
    Winchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default What do i get myself into?

    I wish i had never said yes! A friend of mine asked me if i could do a set of front discs and pads on his ford mondeo, "EASY" i thought!

    After removing all the caliper and pad carier i set to removing the disc, i beat the disc with a hammer for about half an hour and it did not budge! after a while a bit samashed off and the rest was still jammed on the hub!! i had to get the angle grinder off and cut the disc off!! i have never had one this bad!

    here are the pics . . .




    According to ford this "usually" happens to the MK2 has anyone else ever had one this bad?

  2. #2
    Full Member Big Sig's Avatar
    Join Date
    Aug 2006
    Location
    Is a very naughty boy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Did you try to heat it up as well? Never had one stick that badly!!!!
    Now I need a turbo to keep up!

  3. #3
    Regular Member
    Join Date
    Feb 2007
    Location
    North west
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Rusted on ? I would have said sorry mate, got to go... when it snapped.

  4. #4
    Regular Member Jackvectra18's Avatar
    Join Date
    Jan 2009
    Location
    Winchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Im guessing it was rusted on, but once i got it off the hub looked spotless i didnt want to heat it as i was scared of messing up the bearing, i dont want to be doing that as well as discs! lol

  5. #5
    Admin plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    256 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    Had something similar with the calipers on one of them, mate brought his mondeo over and attempted to change the front padd, pistons seized and wouldnt wind back in (i know about one of the sides are 'reversed' when winding in).

    Result being 2 new calipers So the discs sticking to the hubs doesnt surprise me one little bit

  6. #6
    Regular Member
    Join Date
    Feb 2009
    Location
    Carnoustie
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Been there mate with a mondeo I had once, had to do the same with a grinder and chisel the bar steward off!!! apparently common on the mondeo

    Ronnie

  7. #7
    Regular Member mattolly86's Avatar
    Join Date
    Nov 2008
    Location
    oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ive done 5+ new shape mondeo's and about 10 old ones never had this

  8. #8
    Regular Member lofty's Avatar
    Join Date
    Sep 2007
    Location
    @home
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate

    Trim : Elite

    Engine : 1.9 CDTi


    Default

    not good m8..

  9. #9
    Regular Member glenboy's Avatar
    Join Date
    Jul 2007
    Location
    Sunny Dartmoor
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I had exactly the same on my old MK2 Mondeo,thought it was a strange one as never ever had it happened before or since,glad i wasn't the only one..........

  10. #10
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Flippin' Fords eh?!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •