User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: emr valve

  1. #1
    Regular Member
    Join Date
    Feb 2009
    Location
    burnley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default emr valve

    is there a way to test the egr valve or just buy a new one,my car has lost all power,i have cleaned it but still the same.is it possible there could be a block pipe somewhere.
    Last edited by michael29; 1st March 2009 at 12:04.

  2. #2
    Regular Member silverhairedracer's Avatar
    Join Date
    Jan 2007
    Location
    ESSEX
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Did you clean the boost sensor ?,makes a lot of difference when you do .

  3. #3
    Regular Member
    Join Date
    Feb 2009
    Location
    burnley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeh cleaned that also but still no power

  4. #4
    Regular Member keithsimmo's Avatar
    Join Date
    Dec 2007
    Location
    in the engine compartment.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Boost Valve Location

    Can you point me in the location of the boost valve please? Photo if possible.

    Thanks

  5. #5
    Regular Member silverhairedracer's Avatar
    Join Date
    Jan 2007
    Location
    ESSEX
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by michael29 View Post
    yeh cleaned that also but still no power
    What engine 120 or 150 ?
    Seems you and I have similar problem,Cleaned the EGR & the Boost sensor [which is just to left of egr held in place by a single bolt ]
    All seemed well but it has "gone " again with no top end power at all.I am going to check pipes etc now.

  6. #6
    Regular Member keithsimmo's Avatar
    Join Date
    Dec 2007
    Location
    in the engine compartment.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Mine is a [150]BHP do you know if the boost sensor located in the same place? I will have a look tomorow in the light.

    I have the wiring kit Mod for the 3rd injector which I am going to try at the weekend. I'll do a how to with photos and let you know if it resolved the issue. Hopefully have my ODB reader by then as well so i can reset everything.

  7. #7
    Regular Member Drew's Avatar
    Join Date
    Jun 2008
    Location
    Sedgefield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check if your car has the diesel particulate filter fitted, if the egr has been clogged up you could have sooted up the filter, mine sooted up so bad when I fixed all the faults at the inlet side the exhaust blew apart! The filter was not passing anything. Runs better than ever without the DPF but I'm still trying to clear the light on the dash.

  8. #8
    Regular Member keithsimmo's Avatar
    Join Date
    Dec 2007
    Location
    in the engine compartment.
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default DPF

    It's worth a try. Whats the location of the DPF on the [150] BHP. Any photos locations would be good? What is involved in cleaning it?

    thanks in advance.

  9. #9
    Regular Member
    Join Date
    Feb 2009
    Location
    burnley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yeh been told about the dpf filter,but i dont know where it is and what it involves in cleanig out,can anyone point me in the right direction please

  10. #10
    Regular Member silverhairedracer's Avatar
    Join Date
    Jan 2007
    Location
    ESSEX
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default


    Found the problem !!,Went to the car this morning with every intention to find out what was wrong,Knowing it was only the week before all this happened the car was running good.
    Took off the EGR valve again and rechecked & cleaned,
    Took out the boost sensor and cleaned again.
    So next I thought it must be a leak on a pipe started to check them all....and there it was the rubber connector that is on the vacum line to the wastegate valve had perished,spent ages with the parts man at the local stealers just as we were closing in on the part no his system crashed.
    Have done a getbye repair using gaffer tape and the car is back to its usual self.
    Will list the part no as soon as known.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Brake servo Valve (one way valve)
    By Tank988 in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 29th October 2012, 19:48
  2. Replies: 6
    Last Post: 29th July 2012, 13:52
  3. Egr valve, swirl valve problems etc..
    By Vicsterb in forum Engine & Drivetrain
    Replies: 9
    Last Post: 12th January 2011, 15:53
  4. EGR valve / Swirl valve
    By SwavGav85 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 5th January 2009, 17:17
  5. EGR valve and Swirl Valve
    By TUX-VECTRA in forum Vectra C / Signum Troubleshooting
    Replies: 3
    Last Post: 6th July 2007, 00:43

Visitors found this page by searching for:

emr valve

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •