User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: vectra 2005 1.9 sri dti 120,power loss

  1. #1
    Regular Member
    Join Date
    Feb 2009
    Location
    burnley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default vectra 2005 1.9 sri dti 120,power loss

    there is nothing when i accelerate until revs get up to 2500 revs then turbo kicks in,flat spots,turbo lag,i avnt a clue,i give the evg thingy magig a good clean but nowt changed,any ideas chears mick.

  2. #2
    Regular Member mattolly86's Avatar
    Join Date
    Nov 2008
    Location
    oxfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    any warning lights, smoke, chugging cause were gonna need more info mate

  3. #3
    Regular Member big rich's Avatar
    Join Date
    Nov 2008
    Location
    birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra gsi

    Trim : Full heated leather

    Engine : 3200

    Year : 2004

    Default

    Quote Originally Posted by mattolly86 View Post
    any warning lights, smoke, chugging cause were gonna need more info mate
    as above, need to no this first m8.

  4. #4
    Regular Member
    Join Date
    Feb 2009
    Location
    burnley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ok m8,yeh engine management light comes on for one day and of the next,had it on a diagnostics and it said heater control unit,they said one or two ov the heater plugs were pulling more current than the others,i changed them all and no change other than starting better.

    There is no smoking and no chugging,even tho it dosnt seem to want to rev, it dosnt want to stall,cleaned all sensors,even the pressure switch,and that was manckey.

    As soon as i start to drive there is nothing under the pedal,does not feel like clutch is slipping,turbo comes in at 2500 to 3000 revs when it will let me rev that much,strange cos this car was ****** rapid,hope this helps.

  5. #5
    Regular Member benny's Avatar
    Join Date
    Feb 2006
    Location
    dudley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    does it have a dpf ..... if not i would say the egr is sticking or is faulty ....if it has got a dpf you need to get it checked to see if it is blocked

  6. #6
    Regular Member
    Join Date
    Feb 2009
    Location
    burnley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i dont know what a dpf is m8 and where is it

  7. #7
    Regular Member
    Join Date
    Feb 2009
    Location
    burnley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default evg valve

    can you test the emr valve some how or not
    Last edited by michael29; 28th February 2009 at 11:22.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra c loss of power
    By jonnygrim in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 4th December 2012, 10:17
  2. Power Loss Vectra V6 3.0 CDTI
    By renwich in forum Y & Z30DT Specific
    Replies: 32
    Last Post: 7th September 2011, 22:52
  3. Vectra power loss
    By jan63 in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 5th March 2011, 19:48
  4. Vectra CDTi 150 - Loss of Power
    By Chappers. in forum Engine & Drivetrain
    Replies: 22
    Last Post: 4th January 2011, 23:37
  5. vectra 2005 1.9 sri dti 120,power loss
    By michael29 in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 14th March 2009, 15:12

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •