User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Help me return the performance back to my 1.9cdti

  1. #1
    Regular Member
    Join Date
    Aug 2008
    Location
    Leicestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Help me return the performance back to my 1.9cdti

    Hi all,

    Firstly can I apologise as some of this post has been posted previously without resolution and I REALLY would like advise.

    Putting things simply.....

    1. Jan 09 - car was running ok but without some get up and go and the EML was flashing up for longer than normal at startup.

    2. Feb 09 - car has full service / MOT / EML reset - it now runs like a dream - like new again - feel that turbo kick in

    3. Feb 09 - 150 miles after service / MOT the car runs again like before and the EML is back to coming on again longer than normal at start up.

    So....what magic did the service do for 150 miles?

    Prior to the service I decide to get a code reader - this dragged on and I have now had 2 U480 units and neither will read the car .

    My gut feel is EGR hence previous posts (http://www.vectra-c.com/forum/showthread.php?t=68166)

    Please help both with the car problem and the U480 getting a link error......

  2. #2
    Regular Member markd3925's Avatar
    Join Date
    Oct 2008
    Location
    Eindhoven
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra GTS


    Engine : 3.2 V6

    Year : 2003

    Default

    yer egr can cause a lack of power at low rpm

  3. #3
    Regular Member
    Join Date
    Feb 2007
    Location
    North west
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    120 or 150 bhp ? could be stuck swirl valve if its a 150. Try a flush dose of redex, cleaning the EGR is easy mate, it restored my CDTI to its former torque heaven.

  4. #4
    Regular Member
    Join Date
    Aug 2008
    Location
    Leicestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi....

    Its a 150 bhp

    The swirl valve / new inlet mawas done (thankfully under warranty) last August time...so hopefully not that again!

    The bit I am confused about is how it was crap, good for 150 miles then crap again - all because of a standard full service - resetting the EML wouldnt have done anything would it?

  5. #5
    Regular Member
    Join Date
    Aug 2008
    Location
    Leicestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused

    I have done a bit more reading on here.....

    What do people think about the fuel filter being full or water for some reason......

    As I have sadi, the car run as new for 150 miles after the service (which included new fuel filter etc) but is now back to how it was before the service

    please help..............

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Poor performance from 1.9cdti....Check your boost pipes
    By richardn in forum Engine & Drivetrain
    Replies: 296
    Last Post: 31st October 2016, 22:19
  2. Just back from fixing the shambles that is MAS performance....
    By rfc52 in forum Diesel Engine related
    Replies: 48
    Last Post: 19th February 2013, 11:00
  3. Replies: 0
    Last Post: 5th July 2012, 23:27
  4. hi a return back to vauxhall
    By bee in forum Introduce yourself.
    Replies: 4
    Last Post: 27th October 2009, 20:28
  5. Just got back from VXR Performance Centre..
    By phil-t in forum Diesel Engine related
    Replies: 13
    Last Post: 9th May 2006, 21:34

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •